-->>Setup and usage<<--          
A different "subtitles won't play" thread.
#1
Hi Shark007,

I'm a longtime user on my win7 desktop PC and I have no issues at all on that machine (which uses an older version of your codec pack - V4.2.5) as embedded subtitles play automatically without issue, but I have just bought a new Win10 Laptop and I have installed the latest Shark Codecs V8.5.3 onto it but I've found that the embedded subtitles for x264 MP4 files no longer play automatically and I have to click on LAV Splitter white Icon or FFDShow red Icon (does the same in both) in the taskbar to enable the subtitle stream each time I open a file in Windows media player to be able to see the subtitles. If I close and re-open Media Player I have to go through the same "click the Icon, select subtitle stream etc" setup again or the subtitles won't be displayed (it seems to default to "no Subtitles"). However x265 MKV subtitles work perfectly without having to change any menu settings etc so the issue seems limited to MP4's.

I have clicked "Use Suggested Settings" on both 32 & 64bit settings, clicked "Disable Foundation Media" for MP4 in both 32 and 64bit settings and followed the "Setup and Usage" thread you posted but still have this issue.

Here's an image showing the selections I have for FFDShow (left) and the FFDShow Menu in the bottom right which I have to click through every single time to activate the MP4's embedded Subtitle Stream -

[Image: P5VGy.jpg]

Any help would be hugely appreciated as this is causing me a lot of problems.

Many Thanks.........................Ian
Reply
#2
you haven't stated what player you use.
for a 64bit player, use the 64bit app... and for a x32bit player, use the 32bit app


press [Reset All]
select the SUGGESTED settings checkbox
choose to disable Media Foundation for the specific filetype such as [x] disable Media Foundation for MP4

test (an MP4) with no other changes

If you still have issues,
did you make other changes?
did you disable UAC? (you should not do this)
tell me what player you are using.
Reply
#3
(12-10-2017, 04:47 AM)Shark007 Wrote: you haven't stated what player you use.
for a 64bit player, use the 64bit app... and for a x32bit player, use the 32bit app


press [Reset All]
select the SUGGESTED settings checkbox
choose to disable Media Foundation for the specific filetype such as [x] disable Media Foundation for MP4

test (an MP4) with no other changes

If you still have issues,
did you make other changes?
did you disable UAC?  (you should not do this)
tell me what player you are using.

As stated above the Player is Windows Media Player (32bit), Reset pressed for 32bit settings with Suggested Setting selected (with "YES" selected as I watch videos in a 32bit browser) with Direct VobSub selected by default and "Disable Media Foundation" for MP4 and for MKV already clicked.

UAC is Enabled, I have made no other changes to any settings.

All MKV files with subtitles play them automatically without issue, all MP4 files (I have dozens with subtitles) have to have the subtitles manually selected each time a file is opened.

Something in the MP4 settings is defaulting to "No Subtitles" and I can't find out what.

I do not have this problem playing the same MP4 files on my Win7 PC with it's older Codec V4.2.5 pack, where MP4's play subtitles automatically and in VLC I had to edit the "subtitle track" number with the Preferences setup to 0 from -1 to get VLC to play the subtitles embedded in MP4's automatically (-1 was the default which is defaults the subtitles to "off").

Thank You for the help so far.
Reply
#4
In all of my tests, the following works!

press [Reset All]
select the SUGGESTED settings checkbox
choose to disable Media Foundation for the specific filetype such as [x] disable Media Foundation for MP4

You previously mentioned FFSdhow which is disabled by default and not in use at all.
Are you making other changes other than what is suggested above when testing?
Reply




Users browsing this thread: 1 Guest(s)