-->>Setup and usage<<--          
Cannot bitstream AAC
#1
Hello,

For some time now, all video containing AAC are now converted on the fly to PCM instead of bitstreaming directly to my decoder. it used to work perfectly. I'm unsure if it's from windows 10 creator update, but I did ttry to uninstall, reset all, use suggested settings, I tried reverting to ffdshow instead of lav audio, all of them refuse to bitstream aac. ac3, dts, dts hd, dolby true hd all work.

thank you
Reply
#2
press [Reset All]
do not select the SUGGESTED settings.

Some time ago, I set AAC to be decoded by the PC when selecting the SUGGESTED settings .
Reply
#3
(05-01-2017, 05:19 PM)Shark007 Wrote: press [Reset All]
do not select the SUGGESTED settings.

Some time ago, I set AAC to be decoded by the PC when selecting the SUGGESTED settings .

Oh, I always did that because, well, it was the way to do things, press suggested then modify. Do you know where I can change just that settings in the GUI, codec or others? I tried to find it but never found it.

THanks
Reply
#4
Currently it is only accessed through the suggested settings. I'll add a checkbox to the Audio TAB in the next release to specifically enable AAC bitstreaming without needing to avoid the use of the suggested settings.
Reply
#5
(05-01-2017, 05:19 PM)Shark007 Wrote: press [Reset All]
do not select the SUGGESTED settings.

Some time ago, I set AAC to be decoded by the PC when selecting the SUGGESTED settings .

Just tried reset all, enabled bitstreaming back, configure lav splitter and lav audio decoder, no change, still straight to PCM. I also tried using FFDShow and it still show input AAC, output PCM
Reply
#6
Then the Windows speaker setup under your active audio device is set to something other than stereo.
check that and make sure it is set to stereo.

Are you using the Creators Update? If so, try using MPC-BE downloaded from my Tools page.
Just to remove the possibility it is a new issue introduced by Windows.

I do not have an AVR the handles AAC so I cannot test this myself.
Reply
#7
(05-01-2017, 06:47 PM)Shark007 Wrote: Then the Windows speaker setup under your active audio device is set to something other than stereo.
check that and make sure it is set to stereo.

Are you using the Creators Update? If so, try using MPC-BE downloaded from my Tools page.
Just to remove the possibility it is a new issue introduced by Windows.

I do not have an AVR the handles AAC so I cannot test this myself.

Yup I'm under Creator Update, installed it myself. I'm using MPC-HC with Shark codec (every internal disable) but I'll try MPC-BE. I remember I used to have MPC-BE but I switched to HC some time ago, forgot why. I tried Stereo for audio and other configuration, the only thing that change is that when it's set to audio, I receive 2.0 PCM audio from the video (and very low volume because of the downmix) while if I use 7.1 Surround, I get 7.1 PCM audio and the sound is way better (multichannel settings on the receiver then).

Honestly, for the past 6 years, I've been using 7.1 settings because when you get on youtube and other stuff that aren't using the codec, I get 7.1 audio instead of 2.0 channel layout and the sound is much better. Since the rest I'm using 100% bitstreaming for all format, the channel layout never changed anything. If I was listening to 2.0 AAC, I got 2.0 AAC output (and input on my receiver), same for 5.1 AAC, or DTS-HA, etc... I think it's the creator update messing with something and maybe not liking my old 1th generation Intel Graphic Card. I do have some bypass to do on the driver side (which I reinstalled to try) but it doesn't seem to want to bistream AAC.

Thanks!
Reply
#8
None the less, I did recently set LAV to decode AAC to PCM when selecting the suggested settings. So, with that knowledge in mind, I will add the previously mentioned checkbox to the Audio TAB to allow AAC bitstreaming which would revert the suggested settings from taking control of AAC decoding.
Reply
#9
Ok. I did try to use FFDShow (that's how I got the information about input/output) and that didn't change though. I do configure lav splitter to handle all format, and lav decoder too (I tried without touching that too).

Thanks
Reply
#10
Although I cannot test, It is my opinion that AAC bitstreaming depends on 2 things.
1. the Microsoft Audio decoder being active
2. a stereo setting for the speaker count under your active audio device

The new release featuring the AAC bitstreaming checkbox is available from MajotGeeks
Reply




Users browsing this thread: 1 Guest(s)