-->>Setup and usage<<--          
Dolby TrueHD WMC Playback fails
#1
Question 
Hello

Can I just first say thanks very much Shark007 for the work you put into this. It’s helped me a great deal over the years; I think what you’re doing is awesome.

And now on to my current problem…
I have recently rebuilt my HTPC (setup at the bottom of this post) following the failure of the mSATA drive containing the system volume and failure of myself to have a recent backup.
I’ve got everything back up and running the way I like it, which is to bitstream all encoded audio streams to the AVR, preserving multichannel streams wherever possible. My AVR doesn’t support AAC, so I’m using FFDShow to transcode AAC streams to AC3 for bitstreaming to the AVR.
My AVR is only 5.1 but it does support DTHD, which it internally downmixes to 5.1 for 7.1 sources.

The Problem
I have some MKV files with Dolby TrueHD (DTHD) audio streams that WMC refuses to play (details at bottom of post). Incidentally, some of these files have HSBS 3D video streams, but I don’t think that should be a factor in this problem. When I attempt to play these files, WMC transitions to the playback window, the playback progress bar appears but playback does not start. The tray icons for LAV splitter, FFDShow audio & FFDShow video appear and provide the following ‘tool tip’ information when I hover the mouse over them:

LAV splitter: “LAV Splitter”
FFDShow audio: “Input: Dolby TrueHD, <# of channels>, <sample rate>, <bitrate> (bitstream) Output: HDMI bitstream (1402)”
FFDShow video:  “Input: AVC1 (livavcodec h264) Output: <’(NV12)’ or ‘(YV12)’ (depending on the source file)>”

WMP also fails to play the files; however, VLC player does play them, with DTHD bitstreaming to the AVR. So, at least I can use VLC for these files if I can’t get WMC working.

With my current configuration, I’ve tested playback of the following other format files successfully:
  • MKV, H.264, AAC 5.1
  • MKV, H.264, DTS-DS 7.1
  • MKV, H.264 DTS 5.1
  • MKV, H.264, AC-3 5.1
  • MKV, H.264, AC3 2.0
  • AVI, MPEG-4, AC3 5.1
  • AVI, H.264, AC3 5.1
  • AVI, MPEG-4, AC3 2.0
  • MP4, H.264, AAC 5.1
  • MP4, H.264, AAC 2.0
What I've tried so far
I’ve tried the following changes, but none have changed the WMC behaviour when I attempt playback:
  • MPC-BE & Haali’s splitters, instead of LAV for MKV files 
  • Checking ‘disable Media Foundation for MKV’ on the Shark007 AUDIO tab
  • All five H264/5 DirectShow decoder options on the Shark007 H264/5 tab
  • On the SWAP TAB, disabling the Microsoft Audio decoder
  • Processing the problem files with MetaFox and attempting to play the resultant file
  • Playing back files using WMC from Windows Explorer context menu (‘play with’) instead of via WMC/emby classic UI
  • Rebuilt HTPC from scratch (Windows install)
  • Searching shark007 forums for help. Found this post, but from what I could understand, it doesn’t contain a solution for my issue: http://shark007.net/forum/Thread-Dolby-T...lby+truehd
System Setup
  • Hardware: HTPC = Intel NUC D34010WYKH; AVR = Yamaha HTR-3067 (AKA RX-_V377)
  • Drivers: HTPC Display adapter “Intel HD Graphics 4400”, driver version 10.18.14.4889
  • Connectivity: HDMI from HTPC to AVR; HDMI from AVR to Display
  • Media storage: Emby server
  • Playback applications: emby classic installed in WMC, VLC player
  • HTPC OS: Windows 8.1 64-bit with WMC
  • Windows audio playback device speaker configuration: Stereo (so I get bitstreaming to AVR)
  • Codecs and configuration tool: Shark007 ADVANCED x64 Components v10.0.9
Shark007 configuration summary
1. Shark007 SUGGESTED settings, selecting ‘yes’ when prompted about LiveTV playback, with the following changes.
2. Audio tab:
* Checked: 'True HD/DTS HD-MA (HDMI only)'
3. mpg/mp4 tab:
* Check 'disable Media Foundation' for MP4
4. In LAV audio config panel > Formats tab, 'aac' un-checked
5. In the "ffdshow audio decoder configuration" panel > Output pane:
* All boxes are checked in section 'Pass-through (S/PDIF,HDMI)’
* All boxes under 'Output format for uncompressed or decoded streams' UN-checked, EXCEPT FOR 'AC3 (S/PDIF encode mode)'
* 'Encode 5.1 streams only' UN-checked

Test file analysis, from shark007 ‘Analyze a media file’ function
File 1:
Source: http://www.demo-world.eu/download-2d-tra...ssless.jpg
Audio
ID                                       : 2
Format                                   : TrueHD
Codec ID                                 : A_TRUEHD
Duration                                 : 1 min 34 s
Bit rate mode                            : Variable
Maximum bit rate                         : 5 844 kb/s
Channel(s)                               : 8 channels
Channel positions                        : Front: L C R, Side: L R, Back: L R, LFE
Sampling rate                            : 48.0 kHz
Frame rate                               : 1 200.000 FPS (40 SPF)
Compression mode                         : Lossless
Language                                 : English
Default                                  : Yes
Forced                                   : No

File 2:
Audio #1
ID                                       : 2
Format                                   : TrueHD
Codec ID                                 : A_TRUEHD
Duration                                 : 1 h 48 min
Bit rate mode                            : Variable
Bit rate                                 : 1 529 kb/s
Maximum bit rate                         : 2 709 kb/s
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 kHz
Frame rate                               : 1 200.000 FPS (40 SPF)
Compression mode                         : Lossless
Stream size                              : 1.15 GiB (13%)
Language                                 : English
Default                                  : Yes
Forced                                   : No

File 3:
Audio
ID                                       : 2
Format                                   : TrueHD
Format profile                           : TrueHD+Atmos / TrueHD
Codec ID                                 : A_TRUEHD
Bit rate mode                            : Variable
Maximum bit rate                         : 8 040 kb/s
Channel(s)                               : Object Based / 8 channels
Channel positions                        : Object Based / Front: L C R, Side: L R, Back: L R, LFE
Sampling rate                            :  / 48.0 kHz
Frame rate                               : 1 200.000 FPS (40 SPF)
Compression mode                         : Lossless
Title                                    : English TrueHD Atmos 7.1 48KHz
Language                                 : English
Default                                  : Yes
Forced                                   : No


Thanks for your time reading my post and considering my problem.
Reply
#2
(05-17-2018, 09:33 PM)ten-eighty Wrote: My AVR doesn’t support AAC, so I’m using FFDShow to transcode AAC streams to AC3 for bitstreaming to the AVR.

FFDshow is just getting to old to use anymore. It doesn't know what to do with Atmos audio.
Allowing the few AAC files that you have to be decoded on the PC and sending multichannel PCM audio to the AVR for playback would be fine.

Press [Reset All]
select the [x] SUGGESTED settings checkbox
on the mkv TAB, choose to disable Media Foundation for MKV files
on the mpg/mp4 TAB, choose to disable Media Foundation for MP4 files
on the Aufio TAB, choose the HDMI setting (nothing else)

test.

If you have any persistent audio or video playback issues with the above settings in place,
you MAY find it necessary to choose to [x] disable Microsoft's Video decoder on the SWAP TAB.
Doing so will guarantee that Microsoft decoding doesn't interfere with the playback.
Reply
#3
Hi Shark007.

Thanks for your helpful advice.

I've set the configuration as you suggested and also updated to v10.1.0.

These settings are working for most media types but still leave me with a few problem formats.
Full test results are in the attached word document with issues highlighted. Below are the problem formats. I do have a large amount of AAC content so I'm very keen to find a solution for these - that's what had me using the ffdshow codecs previously.

Ref 8
MKV, H.264, AAC 5.1
With Windows speaker config set to Stereo, my AVR receives PCM 2.0 and outputs 2.1 sound
With Windows speaker config set to 5.1, my AVR receives PCM 5.1 but only outputs 2.1 sound

Ref 10
MP4, H.264, AAC 5.1
Same behaviour as Ref 8

Ref 18
WMC FLAC playback fails - audio error C00D0FEA

Disabling Microsoft's Video decoder on the SWAP TAB had no effect on these issue.

I think this boils down to two questions:

  1. What do I need to do to follow your advice for multi-channel AAC sources?
    Allowing the few AAC files that you have to be decoded on the PC and sending multichannel PCM audio to the AVR for playback would be fine.
  2. What do I need to add or change to get WMC FLAC playback working?
Thanks again.


Attached Files
.doc   codec_testing_results.doc (Size: 49 KB / Downloads: 13)
Reply
#4
Unfortunately, it is a holiday weekend here in Canada and I have many friends family members visiting.
I cannot properly test any of this until Tuesday.
Once I get to testing all of this personally, I will have solid answers to get you running.

For your weekend playground, since I have no time for testing at this time . . .
My current idea is to use AC3Filter to do the AAC encoding to AC3 instead of FFDshow.
Once you enable AC3Filter on the config TAB by removing the disable check in the box,
you can then access its settings from the center dropdown menu.
1st, Check the box to use SPDIF (for all intents and purposes, this enables HDMI output)
next, go to the System TAB - uncheck all formats except AAC
then on the SPDIF TAB, check the box to [x] use SPDIF

As far as I know, flac should be working.
Again, until I do some testing personally, I have no answer at this time.
Reply
#5
Thank you, I'll give that a shot a respond with the results.
Testing can wait; enjoy the time with your family Smile
Reply
#6
Did some testing with the updated settings.
There was no change to the signals the AVR reports it's receiving.
I'm not sure how to check whether or not AC3 filter is actually processing the stream.
I'll wait to hear back from you when you've got time again.
Thanks.
Reply
#7
(05-19-2018, 10:38 PM)ten-eighty Wrote: Did some testing with the updated settings.
There was no change to the signals the AVR reports it's receiving.
I'm not sure how to check whether or not AC3 filter is actually processing the stream.
I'll wait to hear back from you when you've got time again.
Thanks.

I have not had time to test . . . I will follow up as soon as possible.
sorry.
Reply
#8
Thanks for the update. No apologies necessary, happy to get your input when you can spare the time.
Reply
#9
I can update you with real life happenings . . .

My vehicle broke down and needed to be towed from the highway.
Now I'm told the engine needs to be replaced but that costs more than the vehicle is worth.
Today, i need to go vehicle shopping. I live remotely and being without a 4x4 vehicle is not an option.

back to you. . .  a.s.a.p.
Reply
#10
Wow, that's rough.
Hope you're able to replace it with something good.
Reply




Users browsing this thread: 1 Guest(s)