-->>Setup and usage<<--          
EAC3 Audio BitStream with WMC
#1
I've been having problems playing certain files lately where they open but get stuck at 00:00.

I began digging into the issue tonight and discovered that all of the problem files contained EAC3 audio.  Upon further investigation my audio card was not showing support for Dolby Digital Plus so I was going to just disable bitstreaming for this format but I upgraded my drivers and voila it now shows support.

After a quick test in Windows Media Player all was looking good, including the receiver showing the proper DD+ text.  However, when I went back into Emby for WMC and tried to play the files they are still doing the same thing in WMC.

Following your recommendations in another thread I performed the following:

- Upgraded both advanced codecs and x64 components to the latest 8.0.3 version.
- Reset all settings to default in both
- Set Shark suggested settings in both
- Disabled Media foundation in both (they are MKV files)

The only thing I did after this was enable bitstreaming.

I am confused as to why it would work in WMP but not WMC.

Any ideas as to other tricks I could try to get this working?

Thanks for your help as always Shark!
Reply
#2
On the 64bit swap tab, disable the Microsoft Audio decoder.
Reply
#3
Thanks for your quick response.


I tried this setting but am still experiencing the same behavior.

Any other suggestions?
Reply
#4
Did you install AC3Filter separately from my codecs?
If so, that is your issue. If not, follow these instructions in the 64bit App...

press [Reset All]
select the [x] SUGGESTED settings checkbox
on the MKV TAB, disable Media Foundation for MKV
On the Audio TAB, set HDMI bitstreaming

The above works for EAC3 on my system without disabling the Microsoft Audio decoder.
Reply
#5
The only codecs I've ever installed on this particular system since the last clean install is your pack.

I did try the same steps you just listed again but it's still not working for me.

Is your system also Win7 x64 or something else?
Reply
#6
I was testing on Windows 10 with Media Center.
Often Windows 7 Media Center will cooperate after disabling the Microsoft Video decoder on the 64bit swap tab.
Reply
#7
The Video Decoder on the swap tab for x64 is already disabled as part of the Shark recommended settings.

Here is something that I just noticed after messing around a bit more.

If I open either the 32bit or 64bit app, and click to Disable Media Foundation on the mkv tab, and then I exit and relaunch the app, the box unchecks itself each time.

Is this expected behavior or is something amok?  Perhaps the setting isn't actually taking?

FYI, I get the same results for this on two different computers.
Reply
#8
you have some weird stuff going on.
In my experience, weird stuff is caused by choosing to disable UAC (User Account Control).
Is this you?
Reply
#9
No I have UAC still enabled on both computers where this is happening.  Have never needed to disable it.

Both are Win7 x64.

I saw a new version 8.0.4 was released so just completely uninstalled, then reinstalled from scratch and still cannot keep that box checked.

On my HTPC where I first started troubleshooting it is really a super vanilla install.  Pretty much just Windows, Emby for WMC, and Shark007.

Not sure what else I could have weird going on but if you have any other suggestions I will gladly take a look and provide any detail required for analysis.

Thanks for all of your help.
Reply
#10
(08-15-2017, 12:29 PM)moviefan81 Wrote: The Video Decoder on the swap tab for x64 is already disabled as part of the Shark recommended settings.

Here is something that I just noticed after messing around a bit more.

If I open either the 32bit or 64bit app, and click to Disable Media Foundation on the mkv tab, and then I exit and relaunch the app, the box unchecks itself each time.

Is this expected behavior or is something amok?  Perhaps the setting isn't actually taking?

FYI, I get the same results for this on two different computers.

1. The Microsoft Video decoder is NOT set to disabled by the SUGGSESTED settings. (EDIT: I'm going to boot up Win7 just to verify what I said here)
2. I cannot reproduce your issue of the checkbox to Disable Media Foundation on the mkv tab not remembering its set state.

These issues are just weird and not reproducible here.
Had you disabled UAC, I could have helped but since that's not the issue here,
I have no suggestions to assist in resolving your issues.
Reply




Users browsing this thread: 1 Guest(s)