-->>Setup and usage<<--          
Getting gray thumbnails for many x265/HEVC videos
#1
Video 
I am using the latest standalone Icaros 2.2.7 Beta 2, and I am getting plain gray thumbnails for many (even most) HEVC videos (all in MKV container). This is the same issue as described by someone else in this post:

http://shark007.net/forum/Thread-x265-fi...9#pid36989

I see that the problem has been acknowledged and pointed out to the Icaros author, as per this post:

http://shark007.net/forum/Thread-x265-fi...4#pid36994


Any new developments on this front?


EDIT 1: Using Icaros 32-bit on Windows 7 32-bit and Icaros 64-bit on Windows 7 64-bit. Same problems on both machines.

EDIT 2: An interesting thing that I accidentally stumbled upon was that when I made an exact byte-copy of one of those MKV files minus the last bye (i.e. trimmed the last byte out), the new [corrupted] file got a normal thumbnail. Not sure what that means but I just thought it might be worth pointing it out.
Reply
#2
Since these are all MKV's, the container may be the issue here. Get Metafox from my tools page, this program is also authored by Xanashi. Metafox will extract the contents from the current MKV and place them into a newly created MKV without altering the contents.

If the new file is properly thumbed, Metafox is capable of processing an entire folder (while you sleep).
Reply
#3
(11-16-2014, 06:07 PM)Shark007 Wrote: Since these are all MKV's, the container may be the issue here. Get Metafox from my tools page, this program is also authored by Xanashi. Metafox will extract the contents from the current MKV and place them into a newly created MKV without altering the contents.

If the new file is properly thumbed, Metafox is capable of processing an entire folder (while you sleep).

I tried it but no luck there. Same problem. I should also mention that I had tried remuxing with three different versions of MKVMerge with no luck there too.
However, it just occurred to me to go back to MKVMerge and remux the MKVs without the SRT subtitle streams, and TADA!

Now who's at fault here? And how to get thumbnails without taking out the subs?
Reply
#4
When you remux them, in mkvmerge extra options for the subtitle tracks, try to set the cues to "none".
Cues are an option that affects the explorer behavior. This helped me to get rid of funky durations reported by explorer, it might help you too, though I don't have any x265 encoded files to check.
Reply
#5
(11-18-2014, 04:30 AM)Lenmaer Wrote: When you remux them, in mkvmerge extra options for the subtitle tracks, try to set the cues to "none".
Cues are an option that affects the explorer behavior. This helped me to get rid of funky durations reported by explorer, it might help you too, though I don't have any x265 encoded files to check.

Brilliant! That did it!

Thanks for the suggestion, though what does setting cues to "none" change and should I expect any side effects for doing this?
Reply
#6
(11-18-2014, 04:30 AM)Lenmaer Wrote: When you remux them, in mkvmerge extra options for the subtitle tracks, try to set the cues to "none".
Cues are an option that affects the explorer behavior. This helped me to get rid of funky durations reported by explorer, it might help you too, though I don't have any x265 encoded files to check.

This was a very interesting find.
I've implemented a fix making use of this information, so you wont have to remux your files to get them to show proper thumbnails any longer.

Please try out the newest build which will be put up in a couple of minutes.
OS: Windows 7 Ultimate x64
Reply
#7
Yes, that's something I discovered while playing around.
On MKV files that have sub tracks like the .ass ones that have a longer duration (aka end after the video end) the video+audio themselves, then explorer will report that duration instead of the real video+audio duration.
So if the .ass file was sloppy made, you can have lulzy durations shown in explorer.
Dunno if I made myself clear here, lol.
Reply
#8
(11-18-2014, 04:38 PM)Lenmaer Wrote: Yes, that's something I discovered while playing around.
On MKV files that have sub tracks like the .ass ones that have a longer duration (aka end after the video end) the video+audio themselves, then explorer will report that duration instead of the real video+audio duration.
So if the .ass file was sloppy made, you can have lulzy durations shown in explorer.
Dunno if I made myself clear here, lol.

I know exactly what you mean.
I haven't fixed this in the property handler yet but if you grab v.2.2.7 b3,
mkv files with hevc tracks should display proper thumbnails now.

Thanks for the hint! :)
OS: Windows 7 Ultimate x64
Reply
#9
I'll, thanks a lot
Reply
#10
After consulting the mkvmerge documentation, I'm even more confused now. Here's what the documentation says:

"--cues TID:none|iframes|all
Controls for which tracks cue (index) entries are created for the given track (see section track IDs). 'none' inhibits the creation of cue entries. For 'iframes' only blocks with no backward or forward references ( = I frames in video tracks) are put into the cue sheet. 'all' causes mkvmerge(1) to create cue entries for all blocks which will make the file very big.

The default is 'iframes' for video tracks and 'none' for all others. See also option --no-cues which inhibits the creation of cue entries regardless of the --cues options used."


So shouldn't remuxing with subtitle cues = "default" have been the same as cues = "none"??
Reply




Users browsing this thread: 1 Guest(s)