-->>Setup and usage<<--          
Getting gray thumbnails for many x265/HEVC videos
#11
(11-18-2014, 04:28 PM)Xanashi Wrote:
(11-18-2014, 04:30 AM)Lenmaer Wrote: When you remux them, in mkvmerge extra options for the subtitle tracks, try to set the cues to "none".
Cues are an option that affects the explorer behavior. This helped me to get rid of funky durations reported by explorer, it might help you too, though I don't have any x265 encoded files to check.

This was a very interesting find.
I've implemented a fix making use of this information, so you wont have to remux your files to get them to show proper thumbnails any longer.

Please try out the newest build which will be put up in a couple of minutes.

That was quick! Big Grin

Will give it a try and report back in a while...
Reply
#12
(11-18-2014, 05:33 PM)Makaveli84 Wrote: That was quick! Big Grin

Will give it a try and report back in a while...

Thanks, I'm looking forward to hear if it works for you.
OS: Windows 7 Ultimate x64
Reply
#13
(11-18-2014, 05:35 PM)Xanashi Wrote:
(11-18-2014, 05:33 PM)Makaveli84 Wrote: That was quick! Big Grin

Will give it a try and report back in a while...

Thanks, I'm looking forward to hear if it works for you.

It does!

Thanks, and keep up the great work. Smile
Reply
#14
(11-18-2014, 06:02 PM)Makaveli84 Wrote: It does!

Good to hear!

(11-18-2014, 06:02 PM)Makaveli84 Wrote: Thanks, and keep up the great work. :)

Will do. ;)
OS: Windows 7 Ultimate x64
Reply
#15
(11-18-2014, 05:28 PM)Makaveli84 Wrote: After consulting the mkvmerge documentation, I'm even more confused now. Here's what the documentation says:

"--cues TID:none|iframes|all
Controls for which tracks cue (index) entries are created for the given track (see section track IDs). 'none' inhibits the creation of cue entries. For 'iframes' only blocks with no backward or forward references ( = I frames in video tracks) are put into the cue sheet. 'all' causes mkvmerge(1) to create cue entries for all blocks which will make the file very big.

The default is 'iframes' for video tracks and 'none' for all others. See also option --no-cues which inhibits the creation of cue entries regardless of the --cues options used."


So shouldn't remuxing with subtitle cues = "default" have been the same as cues = "none"??

It should but that's outdated.
Mosu, the mkvmerge dev enabled it on all tracks (though, it's most certainly not the same one as the video one) along with other useless features.
Reply




Users browsing this thread: 1 Guest(s)