-->>Setup and usage<<--          
HELP - crackling noise when pause/unpause
#1
Hi Shark,

Long time no speak.  I trust you have been well.

I am not convinced that this is a codec issue, but thought you might have an idea or two.

I would really appreciate some ideas on how to solve this issue.

I have an htpc running win7 x64 with an NVidia 500 series board using hdmi out connected to an  anthem mrx 510.   Playback is fantastic, no sound issues.  Amp recognizes DTS etc but when I pause the amp states no signal (video is still ok) .  When I unpause I get this hideous crackle for a sec and then the movie audio continues without issue.  It would appear this issue only plauges Dolby encoded media.  When I play a youtube/imdb trailer or some other windows  based sound the amp reports PCM and I can pause/unpause without crackles.

As for codecs I run an older v8.3.8 advanced 64 codec pack.

Please also note I am only using 2 bookshelf speakers with a sub (only audio/video connection is single hdmi cables from NVidia card to amp).   About as vanilla as it gets  :-)

I super appreciate any ideas!!

Thank you!!
Reply
#2
what player are you using?
Reply
#3
Hi Shark,

I am using the stock windows 7 x64 media player within media center.   I run mymovies.dk as the movie media managed.

Thanks again
Reply
#4
Media Center (WMC) does not use Windows Media Player (WMP) for video playback.
WMC has its own video player built into ehshell.exe. On 64bit OS's, it is a 64bit player.

It is my hope that updating the codecs will solve your issue.
Go to the Help TAB of both Apps and use the [UNINSTALL] button.

Download and install a current release
In the 64bit App, select the checkbox to use the [x] SUGGESTED settings.
If your file is an MKV, go to the mkv TAB and choose to [x] disable Media Foundation for MKV
other container formats have similar checkboxes on their respective TABs

Also know; Only the settings in the 64bit App will affect playback in a 64bit player.
Reply
#5
Hi Shark,

Ok just updated and selected default, set 64 player and disabled foundation as advised.

No change in crackle scenarios.

Anything else you can think of?

THank you
Reply
#6
you'll need to stop using bitstreamed audio.
Decode the audio on the PC instead of on the AVR.
Send multi-channel PCM over HDMI to the AVR.
Reply
#7
(11-11-2018, 03:42 PM)Shark007 Wrote: you'll need to stop using bitstreamed audio.
Decode the audio on the PC instead of on the AVR.
Send multi-channel PCM over HDMI to the AVR.

So I actually called Anthem (amp manufacturer) and told them what was happening.   We ruled out the amp having issues as the cable tv box also pushes Dolby DTS down to the amp and no crackling.   The tech and I suspect that the nvidia audio stream seems to engage the amp to start sending dolby data 'uncleanly'.  The amp is also down mixing from 5.1 to 2.1.

While turning off bitstreaming solves the crackle issue, the sound quality in terms of range drops horribly.   

Do you have any other ideas?  Is this an nvidia issue?  Or a codec issue?

Do you think I should go back to spdif/tos link optic cable for just the audio and disable the nvidia hdmi audio?

Thanks again Shark
Reply
#8
stay with HDMI. Toslink has its own set of issues much greater than hdmi.
Its neither a codec issue nor a driver issue.

It is my opinion that the AVR should not send undecoded garbage to the speakers, ever.
After all, the AVR is the one tasked with the actual decoding of the audio.

In THIS THREAD over at the AVS forums is a user with the same issue as you.
I suggested he look for a small utility that keeps the connection alive between the AVR and PC during a 'pause' which eliminates the issue.
As I stated over there, I cannot remember the name of that utility.
Reply
#9
(11-15-2018, 02:17 PM)Shark007 Wrote: stay with HDMI. Toslink has its own set of issues much greater than hdmi.
Its neither a codec issue nor a driver issue.

It is my opinion that the AVR should not send undecoded garbage to the speakers, ever.
After all, the AVR is the one tasked with the actual decoding of the audio.

In THIS THREAD over at the AVS forums is a user with the same issue as you.
I suggested he look for a small utility that keeps the connection alive between the AVR and PC during a 'pause' which eliminates the issue.
As I stated over there, I cannot remember the name of that utility.
wow very cool.....thanks for the idea.

Ok I reinstalled the latest NVidia drivers and select audio driver.  Uninstalled sound mobo sound card and disabled audio controller in bios.  Made changes to 32/64 shark audio for hdmi with disabled ms audio foundations.    Back to the way it was before.   Found this app http://veg.by/en/projects/soundkeeper/   ran it and it does........absolutely nothing....LOL   same crackle as before.   In fact the description in the avs forum is identical to mine.    The only difference is that my amp says PCM 2.0 all the time.  When I go to play a DTS enabled mkv it displays pcm 2.0 then no signal, static/crackle and then switches to dts.    Every the lads over at anthem tech support were baffled.   Maybe the evga gtx 550 ti Im running just sux at doing sound??   Or maybe its just not engaging the amp in a clean way when required to do bit streaming through hdmi?  Perhaps I should put a call into them?   I am sure they will just pass the buck.  Do you think its the cable?  Its an old (5yrs or so) mini hdmi to full size hdmi.

Oh I evan ran DPC Checker  https://www.thesycon.de/eng/latency_check.shtml  while the system was busy with network traffic to ensure there was no other silliness.   All green.    Anyway...Im super stumped. 

Again, no static/crackle when on PCM if I turn off bitstreaming.    

Thanks again for your help Shark!!
Reply
#10
another similar utility that you should try is spdif-ka
although named spdif it should also work with hdmi.
Reply




Users browsing this thread: 1 Guest(s)