-->>Setup and usage<<--          
Help Please WMC Sound Issue TrueHD
#1
So I have been at it for three weeks now and I'm trowing in the towel for some help. I'm using Windows 10 with Windows Media Center(WMC) connected by hdmi to avr(onkyo tx-nr3030). I have Shark Codecs ver. 8.4.4 32bit and 64bit. I have be through a lot of the forums and can't find one to help my issue. But for this issue I am using the same mkv file from this thread http://shark007.net/forum/Thread-WMC-64-...ues?page=2 . to diagnose with.

                                          Fresh install of both shark codecs I have configured probably a hundred  different ways. My issue is with passthrough to my onkyo avr for use with any dolby sound. Live ota tv through WMC i get dolby to show up with no issue. When it comes to movies thats a total different scenario, I have yet to get a movie to work other than in pcm for sound. 

                                         If I have both 32bit and 64bit reset and use suggested settings I get video and no sound. If I'm under mkv check disable Media foundation on the 32bit side no change, If I check it on the 64bit side(doesn't matter if 32 is checked or not) I get sound but no picture. The only way I can get sound and picture is to check under mkv disable media foundation for both 32 and 64. Then under 32 only, under swap, check disable windows media foundation. Now I still get sound and no Picture but if I'm playing the movie(just sound) and open either one of the shark codecs in admin mode. Video pops up and sound works perfect after that, just in pcm sound quality not dolby. Now with both video and sound working together in pcm if i switch under audio tab and change to true hd HDMI of either 32 or 64 or both, I lose audio but just for movies and not live tv. I have played with under setup lav audio and tried different check marks but nothing is working for me. I feel extremely defeated right now any help would be greatly appreciated.
Reply
#2
Also If I have under mkv, check disable mf and under swap, check disable microsoft video decoder on 32bit or 64bit or both. WMC wont play video or sound and acts like it freezes with WMC Logo top left becomes blurry and time line on bottom doesn't move with frozen white bar.
Reply
#3
make sure that the device selected in Windows audio is set to stereo and that the 2 exclusive mode boxes are checked.
Reply
#4
That is what they are currently set to.
Reply
#5
Media Center is a complicated beast.

try the following in the 64bit Settings Application

press [Reset All]
select the [x] SUGGESTED settings checkbox and answer Yes to the question posed.
on the Audio TAB, select the HDMI setting, and allow the left side to auto set itself to same as input.
On the SWAP TAB, disable the Microsoft Video decoder.
On the MKV TAB choose to disable Media Foundation for MKV
on the H264/5 TAB, check the box to set ffdshow's merit to normal

Use a MKV file for testing
Reply
#6
So I did what you said for 64bit (when trying to check under swap, disable M.V.C. , I had to logout and back in, in order to get a check mark) and just reset all for 32bit(no suggested, no anything, just reset)


Ok so on the amaze lossless mkv file mentioned above in a different thread was used got video and audio still only in PCM 2.0.
I tried a blue ray remux lossless mkv got sound and no video in PCM 2.0. but when I open shark codec in admin mode, when it flashes back after clicking yes for admin rights video starts to work(weird). Live OTA TV  still works fine with dolby.
Reply
#7
Did you disable UAC?  If so, that is cause of all of your problems.
Reply
#8
Side note: under audio tab, setup lav audio(for both 32 and 64bit) none of the bitstreaming format check marks are marked.
Reply
#9
So I changed UAC to never, reboot, reset both codecs and for 64bit, setup as mentioned above. nothing has changed except for no video but sound PCM 2.0 for the blue ray remux mkv. I am no longer able to click yes for admin rights which typically restores the video.
Reply
#10
So not to complicate things but I just installed MPC_BE_x64Edition. I ran the same exact settings as above and the results are. I get video and no audio on both of my test mkv's. The amaze lossless and blue ray remux mkv's. I go under audio tab(64bit) and turn off bit streaming and I get audio PCM. Don't know if this helps at all, just trying different avenues to get bit streaming to work.
Reply




Users browsing this thread: 2 Guest(s)