-->>Setup and usage<<--          
Live TV AC3 DD No Passthrough
#1
I formatted my Windows 10 HTPC to clean install and have one issue.

Running Win10 using Kodi for Live TV, connectd to a Yamaha receiver via HDMI. . Watching tv channel that has Dolby Digital, the receiver is showing PCM. I know before I formatted, passthrough was working.

I installed Advanced codecs, using recommended settings, choosing yes to the TV prompt. Local movie files do passthrough DTS etc, so they work ok.

Here's the stats of the tv channel:

[Image: cF3nBfH.jpg]

You've always managed to solve my issues in the past, so I'm hoping you can once again help fix this, as it's driving my OCD insane!

Thanks
Reply
#2
In the Windows Control Panel | Sound, under the Configuration of your active device, set the speaker configuration to stereo. Any other setting will send PCM to the AVR.
Reply
#3
(03-05-2017, 03:08 AM)Shark007 Wrote: In the Windows Control Panel | Sound, under the Configuration of your active device, set the speaker configuration to stereo. Any other setting will send PCM to the AVR.

Ok, just tried that. No difference. Receiver is still showing PCM.
Reply
#4
Then it is most likely a setting within Kodi.
In your screenshot it shows decoder - AC3
It shouldnt be decoding it because doing this is creating the PCM.
I am not a Kodi user but you need to find an audio setting that will allow audio passthrough
Reply
#5
(03-05-2017, 03:27 AM)Shark007 Wrote: Then it is most likely a setting within Kodi.
In your screenshot it shows decoder - AC3
It shouldnt be decoding it because doing this is creating the PCM.
I am not a Kodi user but you need to find an audio setting that will allow audio passthrough

Passthrough is definitely enabled in Kodi. I've triple checked all Kodi settings.
Reply
#6
(03-05-2017, 03:30 AM)the_scotsman Wrote:
(03-05-2017, 03:27 AM)Shark007 Wrote: Then it is most likely a setting within Kodi.
In your screenshot it shows decoder - AC3
It shouldnt be decoding it because doing this is creating the PCM.
I am not a Kodi user but you need to find an audio setting that will allow audio passthrough

Passthrough is definitely enabled in Kodi. I've triple checked all Kodi settings.

Sorry, it seems that maybe Kodi no longer enables passthrough for Live TV.

That would explain why I"m seeing what I'm seeing. So sure this never used to be the case.

Thanks for your help anyway Smile
Reply




Users browsing this thread: 1 Guest(s)