-->>Setup and usage<<--          
MKV Subtitles always on
#1
Greets

Whenever I play an mkv from within windows 7 WMC the subtitles are always displayed. I check the mkv sub settings in mkvtools and they are not set to forced or default.

I have subtitles set to default in 32 and 64bit shark007 control panels. In shark007 64bit and 32bit control panels I go into the lav splittler, both checkmarks are in the boxes that pertain to enable automatic forced and deliver only forced subs.

I have tried varied combos of each check box and still the subs are always displayed.

I know Im going to feel silly once you point on the answer!!

Thanks again Shark!
Reply
#2
On the Config TAB of the 64bit App, set No Subtitles in the upper right.
Reply
#3
(06-19-2017, 05:47 PM)Shark007 Wrote: On the Config TAB of the 64bit App, set No Subtitles in the upper right.

Hi shark

Appreciate the reply as always. Is there a setting to enable to only display forced subtitles?

Thanks again
Reply
#4
(06-20-2017, 05:17 PM)Gunif Wrote: Appreciate the reply as always.   Is there a setting to enable to only display forced subtitles?

Thanks again

On the 64bit Config TAB, with DirectVobSub selected, use the center dropdown to enter the DirectVobSub configuration.
From there you will see a checkbox [x] only show forced subtitles.

It is rare that this flag is ever set correctly with the video, so . . . Good Luck!
Reply
#5
(06-20-2017, 05:17 PM)Gunif Wrote: Is there a setting to enable to only display forced subtitles?

My previous response will not fix your issue.
I do not use subtitles myself and responded with what little knowledge I had.

Now that I have done actual testing, I have a proper solution for you.
 From the center dropdown menu choose LAV splitter
Click where it says Default and change that to Only Forced Subtitles
Reply
#6
(06-24-2017, 02:21 PM)Shark007 Wrote:
(06-20-2017, 05:17 PM)Gunif Wrote: Is there a setting to enable to only display forced subtitles?

My previous response will not fix your issue.
I do not use subtitles myself and responded with what little knowledge I had.

Now that I have done actual testing, I have a proper solution for you.
 From the center dropdown menu choose LAV splitter
Click where it says Default and change that to Only Forced Subtitles

Hi Sharky

I tried that for both 64 and 32 bit control panels and no joy. Regardless of which combination of check boxes I select it has no effect. Subtitles are always displayed. I also have gone into the mkv file with mkvtoolnix to check the config of subtitles and they are all set to determine Auto and forced is always off.

The only way is to mux out the subs from the mkv file to disable subs. This sux because there is no way to know if the movie has sporadic use of subs for foreign speaking parts.

I am stumped. Subtitle logic is just broken.

Looking forward to figuring this out together.

Regards
Reply
#7
(06-24-2017, 02:21 PM)Shark007 Wrote: My previous response will not fix your issue.
I do not use subtitles myself and responded with what little knowledge I had.

Now that I have done actual testing, I have a proper solution for you.
 From the center dropdown menu choose LAV splitter
Click where it says Default and change that to Only Forced Subtitles

This suggestion is not about a checkbox selection. It is a dropdown menu.

   
Reply
#8
(06-25-2017, 05:04 AM)Shark007 Wrote:
(06-24-2017, 02:21 PM)Shark007 Wrote: My previous response will not fix your issue.
I do not use subtitles myself and responded with what little knowledge I had.

Now that I have done actual testing, I have a proper solution for you.
 From the center dropdown menu choose LAV splitter
Click where it says Default and change that to Only Forced Subtitles

This suggestion is not about a checkbox selection. It is a dropdown menu.

If it was any plainer it would slap me. LoL

That did the trick my friend.

Thanks again for your diligent help!!
Reply




Users browsing this thread: 1 Guest(s)