-->>Setup and usage<<--          
MKV subtitles not working in Windows 10
#1
I received this inquiry in a Private Message from dbDesign.
I refuse to answer privately because that only helps one person.
Answering the inquiry in the public forum helps 100's of people.

Quote:It's me (MediaCenterWorld)
 
It seems all worked, but there is one problem I found out today.
I get now subtitle in Windows 10 MediaCenter (you know which one I mean) from .mkv files
It's not a mkv with separated .srt it's a file with container sub.
When the file opens (trough Emby) there is now LAV icon on the task menu.
I’ve tried to disable Media Foundation, I setup the “dut” input in the LAV Splitter config through the config items, but nothings seems to help.
When the file is played from explorer everything works and LAV Splitter and Direct VobSub are on the task bar.
Both settings in 32 and 64B are the same whiles testing.
I use latest version 5.5.1
What do you think could be the problem ?
Hope to hear from you,
Best Regards, Daniel
Reply
#2
Press [Reset All] to get back to a 'clean installation' - removes any settings from your testing phase for a resolution
selecting the [x] SUGGESTED settings checkbox is the 1st step, then,
on the MKV TAB, choose to [x] disable Media Foundation for MKV
There are similar selections on the MP4 and AVI TAB to solve similar issues with subtitles.
Reply
#3
Oke, but I did a clean install first, so the "SUGGESTED" settings are loaded.
And I tried lots of things, also choose to [x] disable Media Foundation for MKV
Outside MediaCenter it is working, inside MediaCenter it is not.
Reply
#4
follow exactly
open the 64bit Settings Application
press [Reset All]
select the [x] SUGGESTED settings checkbox
go to the MKV TAB (not the SWAP TAB)
choose to [x] disable Media Foundation for MKV (be sure to get only this box)

test Media Center with no other changes.
Reply
#5
did this, but it's not working...........
Reply
#6
I have nothing else to tell you.
Those instructions work fine for 1000's of people, except you.

Did you disable UAC? doing that can break codecs.
Reply
#7
No I did not disabled UAC I never do that.

very strange, but it doesn't work in MediaCenter on a Windows 10 machine
You say that it works for 1000's off people ?
But ass you see where not talking about Windows 7 or 8.1 it's about MediaCenter 10
As I say it is working outside MediaCenter witch MediaPlayer, but it's not working from within MediaCenter (64Bit)
Reply
#8
I am sitting at a Windows 10 system as I type, and test.

I have one last idea... Maybe it just a container problem.

get Metafox from my Tools page. Install it.
drag n drop an MKV that fails to play subs onto the Metafox desktop icon.
Test playback of the new MKV created by Metafox.

Metafox does not touch quality. It just extracts the contents of most media files and places them untouched, into an MKV.
Reply
#9
Well, finally I found what the problem was.
We have a view NAS systems and all Demo files are at two different systems.
It seems that the NAS where I am connected too at this moment have some odd problems.
When I connect at the other one, the same files are 100%
Why it then works outside MediaCenter i realy don't know (it should not ass well)
Strange but it seems just a local problem
 
Thanks for your support and time ;-)
 
Ps: I do not think that 1000’s off people already use MediaCenter 10, do you ?
Reply
#10
(10-20-2015, 01:09 PM)dbDesign Wrote: I do not think that 1000’s off people already use MediaCenter 10, do you ?

yes
Reply




Users browsing this thread: 1 Guest(s)