-->>Setup and usage<<--          
New Release: 3.0.0 FINAL
#1
Good Evening Everyone,

Let's get version 3.0.0 released, so we can move on to the next beta
with new things to try out!

Only a few changes since RC4 in this release:

- Updated Simplified Chinese and Russian localization (Thanks danei and Ligre!)
- Fixed IcarosConfig crash
- Improved compression of the portable build (saved almost 2MB)
- Improved debug logging


Enjoy the new release! ;)


[Icaros v.3.0.0 Final]

[Major Changes]

- [NEW] Brand new modern GUI with advanced customization
- [NEW] Icaros Cache: an internal cache to help speed up thumbnailing
- Dynamic localization of GUI and Icaros Property labels in Windows Explorer
- All settings are now edittable, even when Icaros is activated!
- UI is now resolution-independent, which allows better dpi awareness
- GUI will now save Window position, size and UI settings on exit
- Settings are now placed in appropriate pages
- Added thumbnail offset timestamp option
- It is now possible to register thumbnail provider and property handler seperately
- Added 4 different ways to add new thumbnail filetypes to Icaros:
  Default editting, Presets, Open File Dialog, and Drag n Drop; Last two automatically checks if the filetype is compatible with Icaros
- Added 'Export/Import/Reset All Settings' functionality (on the UI settings page)


[General Changes]

- Added welcome screen on first time use
- Added auto-rotation of MP4/MOV thumbnails with orientation metadata embedded
- Added button to open the Windows Cache directory (on Tools page)
- Added new cli commands to IC (check -?/-help to view them all)
- Added TotalBitrate property to the 'Details Pane' in Explorer
- Improved track info displayed for FLV files
- Improved thumbnailing of incomplete and unseekable files
- Improved general cover parsing code
- Fixed crash when parsing invalid AVC tracks
- Fixed crash when reading PCM tracks in MKV files on 32-bit systems
- Fixed crash when parsing certain invalid AVI files
- Fixed corrupted Windows 10 Apps taskbar icons 
- Fixed width/height properties in some files with H264 streams
- Fixed thumbnailing of some rare formats
- Fixed thumbnailing of certain FLV files
- Fixed gray thumbnails for TS files with HEVC
- Fixed property issues after upgrading or resetting Windows 8/10
- Fixed hang in Flac cover parser when parsing rare invalid flac files
- Fixed bug where WMP would no longer add AVI files when Icaros was handling the properties
- Fixed wrong 'data rate' properties in certain AVI files
- Updated Compilers
- Updated FFmpeg


[Localizations] (in alphabetical order)

- Added Armenian localization (Thanks Aram!
- Added Simplified  Chinese  localization (Thanks danei!)
- Added Traditional Chinese localization (Thanks Chi-Shiuan!)
- Added Danish   localization (Thanks Anon!)
- Added French   localization (Thanks Spirytus and ILVES!)
- Added German   localization (Thanks Mike!)
- Added Greek    localization (Thanks PyroStar!)
- Added Italian  localization (Thanks brunosso!)
- Added Portuguese localization (Many thanks to Rubens)
- Added Russian  localization (Thanks Ligre!)
- Added Spanish  localization (Thanks Parody (zerouser)!)


Icaros 3.0.0 FINAL Installer: Download
Icaros 3.0.0 FINAL Portable: Download
OS: Windows 7 Ultimate x64
Reply
#2
THx

But the probem with mkvs transparency background is still the same((

http://shark007.net/forum/Thread-Windows...ansparency
Reply
#3
Shocked 
(05-17-2016, 03:04 AM)RakotGOD Wrote: THx

But the probem with mkvs transparency background is still the same((

http://shark007.net/forum/Thread-Windows...ansparency

:O

I had forgotten about this. I'll take another look at it soon!
OS: Windows 7 Ultimate x64
Reply
#4
(05-17-2016, 03:43 AM)Xanashi Wrote:
(05-17-2016, 03:04 AM)RakotGOD Wrote: THx

But the probem with mkvs transparency background is still the same((

http://shark007.net/forum/Thread-Windows...ansparency

:O

I had forgotten about this. I'll take another look at it soon!

Hello

On Windows 10 the Icaros cache is still only growing and working when storing the thumbnails but not when retrieving them.

It has never really worked on Windows 10.

Hope you can fix it someday but if you can't fix it thanks anyway for the thumbnailing. Smile
Reply
#5
Bruce, what size do you view your thumbnails in Explorer?

I'm aware the cache support on Windows 10 is inadequate atm, 
I'll look into it, once I have some more time at my hands.
OS: Windows 7 Ultimate x64
Reply
#6
(06-16-2016, 12:20 PM)Xanashi Wrote: Bruce, what size do you view your thumbnails in Explorer?

I'm aware the cache support on Windows 10 is inadequate atm, 
I'll look into it, once I have some more time at my hands.

Hi

I use large and extra large thumbnail size on Windows 10 64 bits Explorer with Icaros dynamic cache enabled.

Icaros itselft works perfect, thumbnails are rendered nice and the correct size. I guess it's just Windows 10 ignoring the Icaros cache because I believe it used to work with Windows 8/8.1

Thanks for your work. Smile

LARGE
[Image: A22i77X.jpg]

EXTRA LARGE
[Image: 7gQDSrQ.jpg]
Reply
#7
Bruce,

I did a lot of testing on Windows 10 yesterday and the IcarosCache,
and so far, the cache actually worked as intended with both large and extra large thumbnails.

It is of course important that jpg is not added to the Excluded filetypes on the cache page, but I 
can only assume that you have it removed since you said the cache was growing properly.

I'm not entirely sure what the issue could be. 
Remember that the cache only works the second time around. That is, the first time a file thumbnails
it will be added to the cache, the second time the file is thumbnailed, the cache will kick in and speed up thumbnailing.
(unless you use IcarosConfig to build the cache first).

One issue I found was that if you do use IcarosConfig to build the cache, jpg thumbnails are
actually generated in smaller sizes than video thumbnails.
You would have to set the 'View Size' in IcarosConfig to 'Large' and 'XL', respectively to Explorers view size.

Hope it makes sense. Let me know if it doesn't.
Also could I 'borrow' a few of your jpg files, just for testing.
OS: Windows 7 Ultimate x64
Reply
#8
(06-19-2016, 10:47 AM)Xanashi Wrote: Bruce,

I did a lot of testing on Windows 10 yesterday and the IcarosCache,
and so far, the cache actually worked as intended with both large and extra large thumbnails.

It is of course important that jpg is not added to the Excluded filetypes on the cache page, but I 
can only assume that you have it removed since you said the cache was growing properly.

I'm not entirely sure what the issue could be. 
Remember that the cache only works the second time around. That is, the first time a file thumbnails
it will be added to the cache, the second time the file is thumbnailed, the cache will kick in and speed up thumbnailing.
(unless you use IcarosConfig to build the cache first).

One issue I found was that if you do use IcarosConfig to build the cache, jpg thumbnails are
actually generated in smaller sizes than video thumbnails.
You would have to set the 'View Size' in IcarosConfig to 'Large' and 'XL', respectively to Explorers view size.

Hope it makes sense. Let me know if it doesn't.
Also could I 'borrow' a few of your jpg files, just for testing.

Did you try 32 or 64 bits Windows 10? I use 64 bits Windows 10 1511 (10586.420).

Yes, "Excluded Filetypes" is empty. Windows igones the Icaros cache for both images and videos.

Yes, that's exactly the way I'm expecting Icaros to work. Then it must be a Windows problem.

I only use Icaros dynamic cache.

I uninstalled Icaros and installed to try it a similar program I found on Google called Mediapreview that also has thumbnail cache and it worked the first time with my Windows 10. Now I'm lost! Sad

Gonna try the last Icaros beta.
Reply
#9
(06-19-2016, 12:27 PM)Bruce Wayne Wrote: Did you try 32 or 64 bits Windows 10? I use 64 bits Windows 10 1511 (10586.420).

Yes, "Excluded Filetypes" is empty. Windows igones the Icaros cache for both images and videos.

Yes, that's exactly the way I'm expecting Icaros to work. Then it must be a Windows problem.

I only use Icaros dynamic cache.

I uninstalled Icaros and installed to try it a similar program I found on Google called Mediapreview that also has thumbnail cache and it worked the first time with my Windows 10. Now I'm lost! Sad

Gonna try the last Icaros beta.


I tested on Windows 10 x64 (build 10565).

Hmm... try with the latest beta and let me know if it still doesn't work for you,
then we'll take it from there.
OS: Windows 7 Ultimate x64
Reply
#10
(06-19-2016, 12:47 PM)Xanashi Wrote:
(06-19-2016, 12:27 PM)Bruce Wayne Wrote: Did you try 32 or 64 bits Windows 10? I use 64 bits Windows 10 1511 (10586.420).

Yes, "Excluded Filetypes" is empty. Windows igones the Icaros cache for both images and videos.

Yes, that's exactly the way I'm expecting Icaros to work. Then it must be a Windows problem.

I only use Icaros dynamic cache.

I uninstalled Icaros and installed to try it a similar program I found on Google called Mediapreview that also has thumbnail cache and it worked the first time with my Windows 10. Now I'm lost! Sad

Gonna try the last Icaros beta.


I tested on Windows 10 x64 (build 10565).

Hmm... try with the latest beta and let me know if it still doesn't work for you,
then we'll take it from there.

Still no luck with the latest beta.

Gonna try with a fresh Windows 10 install and will let you know.

Thanks. Smile
Reply




Users browsing this thread: 1 Guest(s)