-->>Setup and usage<<--          
New Release: 3.0.0 RC 3
#11
(01-16-2016, 01:11 AM)Zulithe Wrote: Would this vulnerability impact Icaros?

If so, can you please release an updated version soon?

It does not affect Icaros.
Reply
#12
Thanks for the confirmation
Reply
#13
Hi

I'm also getting a crash when using the "Rebuild Cache" button on 3.0.0 RC3.

It happens with both only one folder or several folders added to "locations", no matter if they are photos or videos. The dump is huge, too big to upload. I'm on Windows 10 Pro x64. It's the only crash I've found with Icaros. With the dynamic cache enabled Icaros work OK, no crash at all, so it's only "Rebuild cache" related. I will keep testing RC3 to see if I can get generated a smaller dump or find a workaround.


On another related thing: I have the Windows 10 thumbnail cache disabled on the windows registry and only use the Icaros dynamic cache and I find it drags when compared to the Windows cache. I have the Icaros cache folder on a SSD drive so that's not the problem. Icaros dynamically builds the thumbnails very fast but then later retrieves them slower than the original Windows thumbnail cache. Why is that? The Icaro cache folder has the right permissions and everything works OK but not as fast as it could.

Thanks! Smile
Reply
#14
Hi Bruce,

While I haven't been able to reproduce this bug yet, I have received another report stating the same thing. 
I will definitely look further into this problem, and if you could somehow send me a dump file that would of course be very helpful. ;)

As for the other bug, the Icaros Cache doesn't actually work as intended on Windows 10 yet, because MS has made some 
changes to their thumbnail caching since Windows 8.
I have implemented a fix in the upcoming release of Icaros, but I do plan to make a more permanent solution for this
in the future, so new iterations of Windows won't continue to invalidate the Icaros Cache.

On a side note, the Icaros development is currently going a bit slow, due to some RL stuff.
I do have a new build close to being ready, but I haven't had a chance to put in the finishing touches. :/
OS: Windows 7 Ultimate x64
Reply




Users browsing this thread: 1 Guest(s)