-->>Setup and usage<<--          
No DTS-HD with MPC madVr version
#1
I have been using Shark's advanced codecs with Shark's 64 bit MadVR version of MPC. I recently updated Advanced Codecs as well as MPC MadVR. The new version of MPC with MadVR does not allow you to chose DXVA2 Native and DXVA2 Copyback as a the second option. It only allows me to choose one option. I chose DXVA2 Native. I also enabled 4K. The problem is that DTS-HD soundtracks are not being rendered in DTS-HD like they used to be. If I uninstall MPC and just use media player, the DTS-HD lights on my receiver return. Thanks for any help you can provide. I mostly watch 1080P  videos in 5 to 7 channel surround. However, I occassionally also watch 4K movies. The MadVR version of MPC seemed to really smooth out some of the issues I was having. I have an NVIDIA GTX 1050TI video card in my HTPC.
Reply
#2
There is a new hardware option, D3D11 (instead of dxva), give that a try.
Reply
#3
(08-24-2017, 10:38 AM)Shark007 Wrote: There is a new hardware option, D3D11 (instead of dxva), give that a try.

Thanks Shark. Still no go though. Your advanced codecs, with your settings, DTS-HD Bitstream ingredients enabled, 64-bit media player works though. Just no hardware acceleration sadly.
Reply
#4
In the player, view | options
click on audio in the left side and choose your 'audio renderer' on the right side (HDMI)

This wasn't needed in the past - not sure why it is needed now.
Stick with D3D11, it is much better than dxva
Reply
#5
(08-24-2017, 03:52 PM)Shark007 Wrote: In the player, view | options
click on audio in the left side and choose your 'audio renderer' on the right side (HDMI)

This wasn't needed in the past - not sure why it is needed now.
Stick with D3D11, it is much better than dxva

Now I'm not getting DTS-HD or Tru-HD at all, just regular DTS and DD regardless of the player. One step forward two steps back.
Reply
#6
(08-24-2017, 05:08 PM)volumnus Wrote:
(08-24-2017, 03:52 PM)Shark007 Wrote: In the player, view | options
click on audio in the left side and choose your 'audio renderer' on the right side (HDMI)

This wasn't needed in the past - not sure why it is needed now.
Stick with D3D11, it is much better than dxva

Now I'm not getting DTS-HD or Tru-HD at all, just regular DTS and DD regardless of the player. One step forward two steps back.
Update: I reset Windows 10, and now I have everything working, MadVR, DTS-HD, and Tru-HD. I set it up using Shark's suggestions earlier in this thread, but 4K is still pretty choppy. It was much better before I updated. I'll have to mess with it. I believe the problem I was having with DTS-HD and Tru-HD lies in the fact that my AVR will not passthru 4K, so I extend the display. I send 4K directly to my TV, and I send a lower resolution to my AVR. I figured if I set the resolution going to the AVR as low as possible, it would be easier on the video card. I only use that signal for the audio anyway. I think I've discovered that my video card won't stream DTS-HD or Tru-HD at low resolutions. I changed the resolution of the second display to 1080P, and the DTS-HD and Tru-HD lights on my receiver immediately reappeared. If I drop the resolution of the second video feed back down, I can only get DTS and DD. Strange but true. My video card has three HDMI outputs.
Reply




Users browsing this thread: 1 Guest(s)