-->>Setup and usage<<--          
Subtiles not showing in Windows 10 H.265 MKV
#1
Hi,
I have a H.265 MKV file with embedded subtitles (English) that are not showing in WMP on Windows 10. I did a clean (remove the old version using the UNINSTALL button, removed the folders C:\Program Files (x86)\Shark007 and C:\ProgramData\Advanced) install of the latest (7.2.2) advanced coded pack, selected shark007 recommended settings on the 32bit config application, but no subtitles. With H.264, subtitles are Ok! If I use the Movies & TV application, subtitles are displayed as expected. Is there any special settings that need to be done to show subtitles on H.265 MKV files?
Thanks,

Regards,

Heraldo.
Reply
#2
here is a copy/paste from the Setup and usage page

Windows 10 users . . .Video playback problems? No Subtitles showing? Audio bitstreaming issues in WMP or Media Center?
Is the problem with MKV?... go to the MKV TAB, and choose to [x] disable Media Foundation for MKV
Is the problem with MP4?... go to the MPG~MP4 or Windows SWAP TAB, and choose to [x] disable Media Foundation for MP4
Is the problem with AVI?... go to the AVI TAB and select the checkbox to [x] disable Media Foundation for AVI
you can also set a different splitter for better subtitle support; example, gabests splitter for avi supports divx.com subtitles in avi and divx files.
Reply
#3
(03-01-2017, 02:11 PM)Shark007 Wrote: here is a copy/paste from the Setup and usage page

Windows 10 users . . .Video playback problems? No Subtitles showing? Audio bitstreaming issues in WMP or Media Center?
Is the problem with MKV?... go to the MKV TAB, and choose to [x] disable Media Foundation for MKV
Is the problem with MP4?... go to the MPG~MP4 or Windows SWAP TAB, and choose to [x] disable Media Foundation for MP4
Is the problem with AVI?... go to the AVI TAB and select the checkbox to [x] disable Media Foundation for AVI
you can also set a different splitter for better subtitle support; example, gabests splitter for avi supports divx.com subtitles in avi and divx files.

Hi Shark007,

Thanks for replying!

I tried disabling Media Foundation for MKV on the MKV TAB, but subtitles continue not to show. After disabling Media Foundation I noticed that the LAV icon showed on the taskbar. I also tried to change the subtitles settings (changed to advanced, forced subtitles) on the LAV config app, but it also didn´t work!
Any other suggestions?
Thank you!
Reply
#4
I am unable to reproduce your issue.
Have you installed any other codec or subtitle software?
What is the source of your test file? (I've never heard of subtitles working in the Movies and TV app before)
Can it be downloaded somewhere?

On my Tools page I re-distribute a pre-configured version of MPC-BE player.
Could you please test with that player?
Reply
#5
(03-02-2017, 02:36 AM)Shark007 Wrote: I am unable to reproduce your issue.
Have you installed any other codec or subtitle software?
What is the source of your test file? (I've never heard of subtitles working in the Movies and TV app before)
Can it be downloaded somewhere?

On my Tools page I re-distribute a pre-configured version of MPC-BE player.
Could you please test with that player?

Hi Shark007,

Thanks again for the reply.
I don't have any other specific codec packs or subtitle software installed in my computer. I have Cyberlink PowerDirector 14 and DivX 10 installed.
The file was downloaded from torrent and I merged the subtitles using MKVToolNix 9.9.0.
I can upload the file to my one drive and share with you if you want to take a look.
I tested with your pre-configured MPC-BE player and it worked, subtitles show as expected.
Thanks again!
Reply
#6
Although I cannot verify this at this time....
Most likely Divx is helping the Movies and TV app to display the subtitles and at the same time it is hindering DirectVobSub from displaying the subtitles in Windows Media Player. MPC-BE player is using an internal version of DirectVobSub so it is not affected by Divx.
Reply
#7
(03-02-2017, 03:53 PM)Shark007 Wrote: Although I cannot verify this at this time....
Most likely Divx is helping the Movies and TV app to display the subtitles and at the same time it is hindering DirectVobSub from displaying the subtitles in Windows Media Player. MPC-BE player is using an internal version of DirectVobSub so it is not affected by Divx.

Hi Shark007,

Thanks again for the attention on this.
I am not sure if DivX is interfering on this, because I also tested on my Surface Book, which does not have DivX 10 or any other codec pack installed. Only Advanced coded pack 7.2.0, configured the same way as my desktop and the behavior is the same: no subtitles in Windows Media Player.
Reply
#8
To recap, the necessary settings for H265 video in an MKV with subtitles in WMP
[Reset All]
[x] SUGGESTED settings
[x] on the MKV TAB, choose to [x] disable Media Foundation for MKV
The above setting ^^^ would also break the Movies and TV app from playing any MKV

If you have chosen to disable UAC, it is highly likely you are causing your own problems.
Reply
#9
(03-02-2017, 07:17 PM)Shark007 Wrote: To recap, the necessary settings for H265 video in an MKV with subtitles in WMP
[Reset All]
[x] SUGGESTED settings
[x] on the MKV TAB, choose to [x] disable Media Foundation for MKV
The above setting ^^^ would also break the Movies and TV app from playing any MKV

If you have chosen to disable UAC, it is highly likely you are causing your own problems.
Hi Shark007,
UAC is not disable. It is enabled with the default settings.
I tested again with advanced codecs 7.2.2, after another clean install with the SUGGESTED settings in the 32bit application config, with both Media Foundation for MKV enable and disable, and Windows Media Player does not show the embedded subtitles.
If I choose the SUGGESTED settings in the 64bit config application, it really breaks the Movie & TV app. But if I do not use the SUGGESTED settings, Movies & TV app shows the subtitles in the H.265 video.
I appreciate your attention and recommendations on this issue! I will make a donation.
Thank you!
Reply
#10
(03-05-2017, 03:02 PM)heraldo Wrote: If I choose the SUGGESTED settings in the 64bit config application, it really breaks the Movie & TV app. But if I do not use the SUGGESTED settings, Movies & TV app shows the subtitles in the H.265 video.
I appreciate your attention and recommendations on this issue! I will make a donation.
Thank you!

When selecting to use the SUGGESTED settings, the question posed is quite specific and does different things depending on your response (Yes or No). It asks if you use Windows 10 apps and if you answered No, it would definitely break the Movie and TV app. You would need to have answered Yes not to break that app. It should also be noted that choosing to disable Media Foundation for MKV would break the Movie and TV App from playing MKV's.
Your generous donation is greatly appreciated. Thank You.
Reply




Users browsing this thread: 1 Guest(s)