-->>Setup and usage<<--          
Subtitle Workshop - audio only on MP4 and MKV
#1
Dear all,

Can anybody tell me how to configure to enable both audio AND video playback in Subtitle Workshop?

Am working with SW version 6.0b and before installing shark007 would get error on attempting to open MP4 (or MKV). Now file is accepted but only audio plays....

There's an instruction here.....: http://shark007.net/forum/member.php?act...e=lY1V7AAQ

.... but it seems that shark007 has changed since this was written last year (see last 2 comments, that's what I encounter, too) so I would greatly appreciate any instruction on how to proceed from here.....

If someone could find the time to be of help, this would be awesome...
Reply
#2
On the MPG~MP4 TAB, choose to disable Media Foundation for MP4 files
Reply
#3
Thanks for your attention shark007!

However, your suggestion didn't solve the audio only preview....

I also saw that I accidentally had included a completely unrelated link (obviously not paying enough attention to my typing...).... so I'll put in the link to the page hat I meant to link to.....

http://dismantledtech.wordpress.com/2013...-workshop/

Any more thoughts?
Reply
#4
after reading your link, I may have a solution.
On the MPG~MP4 TAB, choose to use Haali's splitter for MP4 files.
(leave Media Foundation for MP4 disabled!)
Reply
#5
Smile 
That's it!

I had already tried activating the haali splitter for MP4 but not in conjunction with disabling the Media Foundation for MP4.....

Apart from that SW's video rendering needs to be set to VMR9 instead of the default but that is already mentioned on the SW website as a possible necessity to facilitate proper preview display for certain files so I kept switching it back and forth.....

Thanks shark007! Thanks for developing the codec pack and your continues support. Very much appreciated indeed!
Reply
#6
Tongue 
....There I go again.... I've run into the exact same problem with Subtitle Workshop, audio without video playback in preview but this time with an MKV container with a x265 file.....

I really don't fancy trying any old setting willy nilly..... that's just gonna do more harm than good I think.... soooooo.... any more suggestions?
Reply
#7
The only thing I can suggest is to set Haali's splitter for 'PC Playback' on the MKV TAB
It MAY also be helpful to disable (uncheck) the Divx.com splitter on that same TAB
Reply
#8
Rainbow 
Dear shark007..... we're good again.... Eventhough it wasn't haali's splitter in this case but you got me on the right page and when Haali's didn't work I tried LAV's splitter on the same page and we were in business with the x265 files..... YAY!

So many, many thanks again and hopefully I will never ever have to disturbe you again....

The only comfort I get from taking up your undoubtfully valuable time, is the knowledge that I know I'm not the only one encountering these problems so next time someone googles this issue they will find this page on your forum and they, too will be helped by you without you even having to lift a finger....

Thanks!
Reply
#9
(10-09-2014, 06:43 AM)Shark007 Wrote: The only thing I can suggest is to set Haali's splitter for 'PC Playback' on the MKV TAB
It MAY also be helpful to disable (uncheck) the Divx.com splitter on that same TAB

I’m running Windows 10 64 bit.  I am trying to get MP4 and MKV containers with H264 encoded video streams to display video in Subtitle Workshop.  I have Shark 007 ‘standard’ version 3.6.1 codec pack installed.  It seems that every guide or video I review for assistance with this issue references GUIs and changeable options I don’t see on my installed version’s configuration tabs.  For example on this forum “…set Haali's splitter for 'PC Playback' on the MKV TAB…” But I don’t see that as an option/choice to select.
 
Would it be possible to help me get this setup referring to the tabs/options on the most current configuration GUI?
 
Also, do I understand correctly that even though my PC is running 64 bit Windows 10, that I should be configuring the Shark 007 32bit application as Subtitle Workshop is 32 bit?
 
TIA

EDIT: Oops - I just downloaded the Advanced Codec pack and I see more of what is referred to. Let me try and follow the guides with the 'proper' version.
Reply
#10
In the spirit of helping out others, here is what worked for me to enable the video preview when using Subtitle Workshop to edit srt subtitle files associated with H264/5 encoded video in MKV and MP4 containers.  Some of this might not be 'necessary', but it worked for me so I didn't go back and toggle everything to see which steps/choices are superfluous.


I hope this might be useful to someone else.

Install Shark007 “ADVANCED codec pack.

Both a 32 bit and 64 bit configuration applet is included.  For Subtitle Workshop you only need to configure the 32 bit version.

Run the Shark007 32 bit configuration applet as an Administrator.

On the MPG~MP4 TAB select “Use Haali’s splitter” under ‘MP4 Playback’ and then check the box next to “disable Media Foundation for MP4”.

On the MKV TAB select “Use Haali’s splitter” under PC Playback and check the box next to ““disable Media Foundation for MKV”.

Uncheck the “Enable the Divx.com MF splitter” on the left side of the page if it is checked.

On the ‘Config’ TAB under ‘Subtitle Control’ select “FFDSHOW DXVA”.

On the ‘Configuration Items’ drop down menu (just above the Shark007 logo) select “FFDSHOW DXVA”

On the configuration pop-up window that appears, ensure that “DirectShow control” is highlighted on the left side and then check the box next to “Use ffdshow only in:” which is found in the grey panel to the right. Click “Apply” and then “OK” to close the configuration window.

On the “32bit Settings Application” main window, click on the “H264/5” TAB.

In the ‘H264/5 DirectShow decoder’ box select “Use FFDSHOW DXVA H264”.

On the left side check the box for “set the merit of ffdshow to normal”.
Reply




Users browsing this thread: 2 Guest(s)