-->>Setup and usage<<--          
W7: Thumbnail Filetypes does not work
#1
As the title says, the thumbnail filetypes simply doesn't work. It thumbnails all filetypes no matter what is in the 'to thumbnail' box.

In this picture I have a sample of files with Icaro disabled. MKV, JPG, PNG, SWF, and PNG. I currently have Icaro set to the 'audio only' setting simply to demonstrate that none of the filetypes listed will be generated thumbnails when I turn it on.
http://puu.sh/zPcNr/51d61215c6.jpg


When enabled, all filetypes get thumbnails even though none of them are listed.
http://puu.sh/zPcP6/0b56a221b6.jpg

Currently running version 3.0.2, but this has been a issue I've had for a long time. Running Windows 7 SP1.
Reply
#2
Thumbnails get cached (for faster loading on next access) and turning Icaros off for certain types does not remove them from the cache.
You'd have to run the Windows Disk Cleanup utility (found in Windows Administrative tools) to delete the cached thumbnails.
Reply
#3
I've done that a dozen times. Whenever I go to change the setting of Icaro I make sure to empty the windows thumbnail cache and restart explorer.

To clarify; in troubleshooting, I'll uninstall Icaro and delete the Windows thumbnail cache so that the thumbnails look like they do in the 1st picture. I'll reboot, check the thumbnails and see they are still like they are in the 1st picture, then I'll re-install Icaro and enable thumbnailing again.
Reply
#4
Yeah, this one is strange, I'll give you that. As Shark007 said, the cache would be the obvious culprit.
I've just tested it on my Windows 7 system, and it all worked as expected. Only the filetypes in the 'Thumbnail Filetypes' box
got registered and thumbnailed. 

Something must be slightly different on your system. Are you on a user or admin account?
Have you tried using the 'Reset thumbnail filetypes' button on the Tools page of IcarosConfig before you re-activate the 
thumbnailing?
OS: Windows 7 Ultimate x64
Reply
#5
Admin account, and everytime I went to clear the thumbnail cache I would reset the thumbnail file types.
I've tried deleting everything I could- from the Roaming folder, to uninstalling and making sure the Windows cache was cleared before rebooting and re-installing Icaro. All to the same problem.
Reply
#6
The only thing I can think of being wrong, could be the Windows registry permissions.
Do you have any experience with the Windows registry?
OS: Windows 7 Ultimate x64
Reply
#7
Yep. Just point me in the right direction.
Reply
#8
Alright, start out by checking the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Icaros

If you look at the 'Thumbnail Extensions' string value, does it match the values you see in IcarosConfig?
OS: Windows 7 Ultimate x64
Reply
#9
Yes they match.
Reply
#10
Okay, make sure "mkv" is not in the list. Keep Icaros deactivated while doing this.
Check the following key in the registry:

HKEY_CLASSES_ROOT\.mkv\ShellEx

It should be empty right? Activate Icaros now without mkv in the list.
In the registry press F5 and see if two subkeys has been added to the above key.
OS: Windows 7 Ultimate x64
Reply




Users browsing this thread: 1 Guest(s)