-->>Setup and usage<<--          
W7: Thumbnail Filetypes does not work
#11
http://puu.sh/zPRkD/c213860b98.png

The folder was not empty with mkv not being in the list. Even when I go to tools and do the entire resetting process, the keys remained.
Reply
#12
Ah okay, I see the issue now. 
Somehow these keys have been kept in place even after the thumbnail provider has been deactivated.
Icaros always does its best to keep the registry in the same state it was before Icaros was registered,
which is why these keys don't get removed. (This is to preserve the settings of other possible third party shell extensions).

The 'Reset native filetypes' button only puts all the native filetypes like avi, mp3 etc back to their system default values,
but doesn't affect filetypes such as mkv (on Windows 7).

So here is how you fix your current setup:

1. Open IcarosConfig. Choose the 'COMMON' preset on the thumbnailing page. Activate thumbnailing if it wasn't already.
2. Go to the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Icaros\ThumbBackup

3. Delete all the values except (Default)
4. Deactivate Icaros thumbnailing
5. Use the 'Reset native filetypes' button
6. Finally set the filetypes you want in the 'Thumbnail Filetypes' list and activate Icaros one more time. 

That should fix your problem.
OS: Windows 7 Ultimate x64
Reply
#13
I think this was the heart of the issue, but something is still misbehaving. 

The thumbnail file types seems to work with all types besides swf files. Even with nothing in the thumbnail filetypes list, swf files get generated thumbnails, where as mkv and flac do not (unless they're added to the list).
Adding mkv and flac to the list and activating Icaro generates thumbs for them, but swf still seems to be generating thumbs whether they're in the list or not when Icaro gets activated.
Reply
#14
That's my bad, swf isn't in the 'COMMON' preset. 
I wasn't sure how many filetypes were affected, and whether or not to use the 'MOST KNOWN' preset instead.

If swf is the only other filetype that bothers you now, there is an easier solution:

1. Deactivate Icaros, and go to the following key:

HKEY_CLASSES_ROOT\.swf\ShellEx

2. Delete all sub keys
3. Reactivate Icaros
OS: Windows 7 Ultimate x64
Reply
#15
That's done it! Thank you so very much for your help!
Reply
#16
You're most welcome! ;)
OS: Windows 7 Ultimate x64
Reply




Users browsing this thread: 1 Guest(s)