-->>Setup and usage<<--          
WMC, 64-bit, Windows 10, TrueHD 7.1 Issues
#1
First, thank you Shark007 for your great work and support of these codec packs!

I have given this about all I can and cannot find a solution so it's time to post.

I have downloaded sound demos (MKV video files) from Dolby that are 7.1 as well as ATMOS . I have been all over this forum and seen and tried the solutions given for Windows playback issues in WMP and WMC, such as Swap tab, Disable Microsoft Audio codec, disable Windows Media Foundation in the MKV tab, etc.

I am wondering if I could have had success already if I removed WMC and installed the 32-bit version of WMC (assuming that would even work on 64-bit Win10) but here's what I've been able to get working.

Fiddling with the 32-bit control panel of your codec pack I can get WMP to play all my audio files and every format passes through to my Onkyo receiver perfectly.....I did have to make changes to the default settings.

In WMC, anything that's 5.1 or older works perfectly. 7.1 and ATMOS will not play. The seek bar will stick on 0:00. I've tried the disable audio option in the Swap tab, even though that won't work as a long-term solution since I use WMC for LiveTV, and it doesn't fix the issue. I've tried every combination I could find/think of in the 64-bit control panel to get those files to play in WMC but they won't.

Do you think there is a way to get 64-bit WMC to work with these newer audio formats, TrueHD and Atmos that won't break LiveTV?

I wish this was a clean install of Windows....I had at one point installed Cyberlink's virusware software to play Bluray discs...but have since uninstalled it.

Do you happen to know if 32-bit WMC will install and work on 64-bit Windows 10?
Reply
#2
I discovered a small bug in my App when testing this. I'll fix that in the next release and give you a workaround here.
FFDshow audio was getting used by mistake for this format.
The workaround won't be required in future releases. current is 7.1.0 --- I'll release 7.1.1 very soon to fix this
Another solution would be to choose the Standard Codecs release instead which does not include FFDshow at all.


Do the following in the 64bit Settings Application
press [Reset All]
select the [x] SUGGESTED settings checkbox
On the MKV TAB, choose to [x] disable Media Foundation for MKV
on the Audio TAB, select the HDMI setting and allow the left side to auto-set itself to Same as input
___ workaround___
go to the Misc TAB and choose [x] DO NOT use FFDshow.
___end workaround___

Just to be sure, for this to work properly, an HDMI cable must go directly from the PC to the AVR
forget 32bit WMC. and the recommend version of WMC to use with Windows 10 is version 8.8.1 - 64bit
Reply
#3
Awesome, thank you very much for that...I'll give this a try tomorrow probably. I am sure it will work, or your next release will. I'm not in a hurry...still have speaker wire hanging out of my ceiling :p

Definitely didn't want to blow up WMC....have a LOT of things set up in it......happy to not have to even consider going to 32-bit WMC

I do use HDMI directly to my AVR

thanks for the help
Reply
#4
okay, so I removed the old version of the codec pack, rebooted, then installed 7.1.1

I didn't try WMC with the stock settings. I disabled Microsoft in the MKV tab and changed the Audio setting to HDMI only.

My troubled 7.1 files this time cause WMC to crash instantly.

I then unchecked the disable FFDShow in the Misc tab and the videos would then start to open but stick at 0:00

I tried disabling the Microsoft Audio decoder in the Swap tab, no change.

I failed to mention in my initial post that there is one particular 7.1 file I got from Dolby that plays perfectly and passes 7.1 audio fine in WMC, all the others fail.

All the 7.1 files continue to play fine in WMP.

Any ideas?
Reply
#5
(01-31-2017, 07:09 PM)Shark007 Wrote: Do the following in the 64bit Settings Application
press [Reset All]
select the [x] SUGGESTED settings checkbox
On the MKV TAB, choose to [x] disable Media Foundation for MKV
on the Audio TAB, select the HDMI setting and allow the left side to auto-set itself to Same as input

Is Windows set to use the correct device for audio output? (its usually a graphics device)
rightckick the speaker icon in the systray near the clock and choose playback devices to check
A green checkmark will indicate which is in use.
If so, that speaker configuration should be set to stereo for that device to bitstream (allow the AVR to decode the audio)
any setting other than stereo will cause decoding on the PC and only output multi-channel PCM

and to be sure, the HDMI option is selected in both the 32bit and 64bit Settings Applications?
If you change one, it will affect the other without notifying you
Using the button to [setup LAV audio] should show that all the bitstreaming boxes are checked
Reply
#6
I'll check on these things when I get home, but would Windows Media Player pass all the audio perfectly to my AVR if those settings in Windows you mention were wrong? Even WMC passes all 5.1 audio perfectly to my AVR, and it passes the 7.1 audio on that one file fine. It's just that the rest of my 7.1 files get stuck at 0:00.

I did choose HDMI only audio for both 32-bit and 64-bit...I have to do that to get WMP to pass the audio properly to my AVR.

I'll check the things you mentioned late tonight. Thanks
Reply
#7
There is a button on the Misc TAB, [Analyze a media file] which will tell you the exact contents of any media file.
When playback seems stuck, that is an indication the FFDshow is trying to decode the file.

Testing right after following these instructions should work for MKV files. . .

Do the following in the 64bit Settings Application
press [Reset All]
select the [x] SUGGESTED settings checkbox
On the MKV TAB, choose to [x] disable Media Foundation for MKV
on the Audio TAB, select the HDMI setting and allow the left side to auto-set itself to Same as input

EDIT: just to put it out there, If you have disabled UAC, (User Account Control), you may have caused your own problems.
Reply
#8
(02-02-2017, 10:13 AM)Shark007 Wrote: There is a button on the Misc TAB, [Analyze a media file] which will tell you the exact contents of any media file.
When playback seems stuck, that is an indication the FFDshow is trying to decode the file.

Testing right after following these instructions should work for MKV files. . .

Do the following in the 64bit Settings Application
press [Reset All]
select the [x] SUGGESTED settings checkbox
On the MKV TAB, choose to [x] disable Media Foundation for MKV
on the Audio TAB, select the HDMI setting and allow the left side to auto-set itself to Same as input

EDIT: just to put it out there, If you have disabled UAC, (User Account Control), you may have caused your own problems.

that would be silly....I've never understood why anyone would disable UAC completely. Wink
Will post results shortly
Reply
#9
Okay, I did the exact steps of your last post, and WMC crashes instantly when playing those 7.1 files. 
I have to go to the Misc tab to uncheck the disable FFDShow setting to prevent the instant crashing....but that just brings me back to the stuck at 0:00 issue.


I did check the speaker settings in Windows at they appeared to be on stereo, instead of 7.1. But after changing it to 7.1, nothing gets decoded properly. Even though my AVR shows 5.1 or 7.1 audio coming in, it is actually just stereo sound coming out. The one 7.1 file I have that has always played fine in WMC, is a sound check video...that pushes audio to each of the 7 speakers one at a time....and that's how I can verify whether or not 7.1 sound is truly coming out of my receiver. Before I changed the Windows speaker config setting that video was playing true 7.1 audio....after changing the Windows setting to 7.1 it only played in stereo.

Definitely a pain in the butt....and I'm sure it ultimately boils down to a Windows issue....but this computer is the only PC I have ever had/used that's connected to a 5.1 or newer AVR.....so I'm still relatively green messing with this particular issue.

Wondering if there isn't some sort of simple audio only codec I can install with no other codec packs that will allow these to play......or at least, I wonder what the absolute minimum install would be for these to work.

Still odd to me that I can get everything working perfectly with your codec pack and using only Windows Media Player...even before messing with the Windows speaker config options.
Reply
#10
(02-02-2017, 10:13 AM)Shark007 Wrote: There is a button on the Misc TAB, [Analyze a media file] which will tell you the exact contents of any media file.

Along with checking the file contents, another possible file issue is the construction of the MKV file themselves. On my Tools page is a program called Metafox. That program can make an MKV from just about any source but it will also extract and re-construct from an existing MKV to a new MKV. Worth a shot. On a side note, if your test files are other than MKV, you should know that TS derivatives can be a real problem until they get converted to MKV files.
Reply




Users browsing this thread: 1 Guest(s)