-->>Setup and usage<<--          
WMC MKV Playback
#1
Had advanced installed for months with no issues. Installed update yesterday and for some reason now, WMC Emby won’t play any MKV files but Media player plays everything fine. I read on another post the below by Shark. I put a X in disable media foundation on both 32 & 64 but when I go back into either the X hasn’t saved.

I’m at a loss whether this is coded related or WMC issue. Any help would be amazing.

“In the 64bit Settings Application,
press [Reset All]
select to use the [x] SUGGESTED settings checkbox
If the file is MKV, go to the MKV TAB and select to [x] disable Media Foundation for MKV”
Reply
#2
On the 64bit Swap TAB, choose to [x] disable Microsoft's Video decoder
Reply
#3
(10-19-2017, 02:27 PM)Shark007 Wrote: On the 64bit Swap TAB, choose to [x] disable Microsoft's Video decoder

I tried that on 64 and 32 but no joy.
Reply
#4
In the 64bit app....

press [Reset All]
choose to use the [x] SUGGESTED settings
On the Swap TAB, choose to [x] disable Microsoft's Video decoder

test with no other changes

The above assumes Emby is using the WMC player
I have never used Emby so what player is in use is just a guess here

WMC = Windows Media Center
Reply
#5
(10-19-2017, 03:33 PM)Shark007 Wrote: In the 64bit app....

press [Reset All]
choose to use the [x] SUGGESTED settings
On the Swap TAB, choose to [x] disable Microsoft's Video decoder

test with no other changes

The above assumes Emby is using the WMC player
I have never used Emby so what player is in use is just a guess here

WMC = Windows Media Center

Yeah it's just a front for Windows Media Centre, used to be called Media Browser. I tested the above and got a result, it plays, but when I go and change the audio settings back to HDMI I then get the playback issues again. So I reset settings, never clicked disable Microsoft's Video decoder this time and tested. It played fine, so there is something in audio settings that is preveting playback when using HDMI I guess?

But media player still plays everything fine and is passing DTS/DD through HDMI perfect.
Reply
#6
Windows Media Player and Windows Media Center are 2 different players.

Disable the Microsoft Video decoder on the 64bit Swap TAB, set Audio to HDMI on the Audio TAB and then check that your Windows sound device (your AVR) is set to 'Stereo'.
Disabling the Microsoft Video decoder allows LAV splitter to be used. This is an important step.
Reply
#7
(10-20-2017, 03:25 AM)Shark007 Wrote: Windows Media Player and Windows Media Center are 2 different players.

Disable the Microsoft Video decoder on the 64bit Swap TAB, set Audio to HDMI on the Audio TAB and then check that your Windows sound device (your AVR) is set to 'Stereo'.
Disabling the Microsoft Video decoder allows LAV splitter to be used. This is an important step.

No go, still fails. it looks like it's about to start then just goes back to "press play" screen.
Reply
#8
(10-20-2017, 03:25 AM)Shark007 Wrote: Windows Media Player and Windows Media Center are 2 different players.

Disable the Microsoft Video decoder on the 64bit Swap TAB, set Audio to HDMI on the Audio TAB and then check that your Windows sound device (your AVR) is set to 'Stereo'.
Disabling the Microsoft Video decoder allows LAV splitter to be used. This is an important step.

Got it, in the Windows audio settings there is two exclusive settings that need ticked, only one appears to be done. Once both clicked, issue resolved.

Found it on this page on your forums.

http://shark007.net/forum/Thread-Setup-and-usage

Also under your device in Control Panel | Sound, [your active device] 

properties --> Advanced, the 2 exclusive mode boxes need to be checked for bitstreaming



Thanks so much for all your help, great Codecs!!!
Reply
#9
Glad you resolved it because I was running out of ideas!   Smile
Reply
#10
(10-20-2017, 04:21 AM)Shark007 Wrote: Glad you resolved it because I was running out of ideas!   Smile

This solution works but creates the problem in live tv in wmc. Play works but ff not working/causing crash.
Is this possible to solve?


The only player which gives playback issues on these files is wmc in w7.
Reply




Users browsing this thread: 1 Guest(s)