-->>Setup and usage<<--          
WMP unable to play standalone AAC files on Win10
#1
I've got a bunch of songs I've downloaded from YouTube. To save on processing power without loosing any audio fidelity I've demuxed the videos and saved them as standalone audio files. They used to play flawlessly on Windows 7 but since upgrading to Windows 10 I can't get them to play in Windows Media Player. For some reason instead of giving the standard error of the file being unsupported WMP acts like it's playing the file except that the seek bar sits at the left and never moves. The play button turns into a pause button and everything as if the file is playing.

MediaInfo on the files:


General
Complete name                            : S:\Contents\To Lotus\vids\#music\AViVA - GRRRLS.aac
Format                                   : ADTS
Format/Info                              : Audio Data Transport Stream
File size                                : 3.48 MiB
Overall bit rate mode                    : Variable

Audio
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format version                           : Version 4
Format profile                           : Main
Bit rate mode                            : Variable
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 44.1 kHz
Frame rate                               : 43.066 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 3.48 MiB (100%)
Reply
#2
are you using a recent release of the codecs?
If so, press [Reset All] in both the 32bit and 64bit Settings Applications.
test with no other changes
Reply
#3
(07-09-2018, 05:02 AM)Shark007 Wrote: are you using a recent release of the codecs?
If so, press [Reset All] in both the 32bit and 64bit Settings Applications.
test with no other changes

Just updated from 10.3 to 10.3.7 (uninstalled 10.3 first) and clicked the "reset all" buttons. Still doesn't seem to be working. I suspect it's an issue with Windows 10 being stupid.
Reply
#4
sorry, I've been busy.
If the file is an MKV, go to  the mkv TAB and choose to [x] disable Media Foundation for MKV
There are similar options on the avi and mp4 TABS as well

I see that the file has an extension of aac. I have an aac sample which plays fine in WMP.
You may have to choose an alternate player (MPC-BE from my Tools page) to play your file though.
Reply
#5
No worries, I hadn't replied for a few weeks. Your reply was nearly instant in comparison.

After disabling all the media foundation options I could find, to no avail, I went around disabling more Microsoft based stuff and found one that fixed the problem. "Disable Microsoft's Audio Decoder" under "Swap" fixed the issue. Is it possible checking that box might cause issues for other codecs or containers/muxers?

Btw, for future reference the file is an audio only container. In fact I'm not sure if it's even a container.
Reply




Users browsing this thread: 1 Guest(s)