-->>Setup and usage<<--          
WMP will not play avi files
#1
I have been using these codecs for a number of years. I updated them to the most recent versions, set up the Shark suggested setting for both 32 and 64 bit, disabled Media Foundations for AVI, and disabled Windows DMO video codecs under swap tabs. It frustratingly WILL NOT play an avi file. Everything else works fine.  Any clues how to make this work?
Reply
#2
re-enable the DMO codecs
need more help? select to use LAV for AVI playback
Reply
#3
(04-10-2017, 03:49 PM)Shark007 Wrote: re-enable the DMO codecs
need more help? select to use LAV for AVI playback

re enabled DMO codecs....no love. Selected LAV for AVI playback...."Windows Media Player has stopped working".

This is driving me nuts.
Reply
#4
did you install another codec like xvid? if so, uninstall it.
Reply
#5
(04-10-2017, 05:05 PM)Shark007 Wrote: did you install another codec like xvid? if so, uninstall it.

No. Have only installed the Shark codecs. In fact in attempting to resolve this issue I uninstalled and reinstalled the Shark codecs. While uninstalled the AVI file played fine.....go figure.
Reply
#6
pressing [Reset All] should have the same effect as uninstalling.
selecting the [x] SUGGESTED settings should allow subtitles with playback.
Any other settings you choose would be to play troublesome files.

Maybe your choice of audio settings is causing a problem.
Reply
#7
(04-11-2017, 03:40 AM)Shark007 Wrote: pressing [Reset All] should have the same effect as uninstalling.
selecting the [x] SUGGESTED settings should allow subtitles with playback.
Any other settings you choose would be to play troublesome files.

Maybe your choice of audio settings is causing a problem.

Well after messing with every setting I could think of that might have any relevance I tried disabling Microsoft's Audio Decoder on the 32 bit Swap Tab. That made WMP play the avi files.  Yaaay!  Then I realized that the edited OTA TV recordings that I have, which are MPEG-PS files with 6 channel AC-3 audio, would not play. The thrill of victory...the agony of defeat. Was just about ready to uninstall the whole thing, but tried disabling Microsoft"s Video Decoder on the 32 bit SWAP tab as well as the Audio decoder and eureka, everything plays. What I don't understand is why making this work after years of using the vanilla Shark suggested settings worked in the past.
Reply
#8
I came across a series of AVI files that were giving me issues.
I used Metafox (it can be downloaded from my Tools page) 
to instantly create mkv's from those AVI's and the MKV's play without issue.
Reply




Users browsing this thread: 1 Guest(s)