-->>Setup and usage<<--          
WMP12 Internet Radio Streaming thru LAV Not Working
#1
On my w7x64 system, internet radio streaming in WMP12 (32 and 64 both) works fine with Shark007 uninstalled.

With the last few versions of Shark007 Advanced (8.5.8-8.6.0), that streaming ability has failed.

My normal Shark007 setup tweaks things so that mp3, flac, and m4a are all handled by LAV thru the DirectShow pathway.  This works fine for normal file-playing inside WMP, but...

WMP Playlists with a path to a streaming radio website do not work - they buffer very slowly and then restart, without
any sound.  [if I paste the playlist's url into a browser it plays just fine].

I _THINK_ it's something in the LAV Splitter - Its icon does appear in the tray, along with LAV Decoders', and the LAV Decoder "status" tab shows it's decoding an mp3 and the output level-bars are at 100% [always], but no sound.  It [wmp] just repeats the buffering... and loops; occasionally I do hear a click before looping.  I remember when I initially made these radio playlists and added them to WMP that they worked just fine.  [I have not gone back to an older version of shark to test this hypothesis tho; I might try that later this week if time allows]. 

In the meantime, does any one else have a solution?  I looked at the LAV forums and there is no mention of recent changes to the LAV Audio filters.  Thanks...

-=Paul=-
Reply
#2
LAV filters are based on FFmpeg.
This sounds like an issue with FFmpeg so I suggest you monitor the LAV repository for an FFmpeg update.
The last FFmpeg update was Oct 1st.
Once you see that FFmpeg is updated in the repository, my release following that update will contain that fix.
Most likely (but just a guess), this will occur within the next few days to a week.
Reply
#3
FWIW, I have found out how to minimize my issues with LAV and WMP radio streaming: the default LAV Splitter buffer size is very large - it causes LAV to buffer up a lot of the stream before playing it; sometimes it take 30-45 seconds to "latch up" and start playing an internet radio station [an mp3/aac HQ feed at the typical 40Kbps speed].  I changed these defaults to:  Max Queue Memory: 128, Max Queue Packets: 64. and Stream Analysis Duration: 500.  Now it starts playing the station in just a few seconds, like WMP does by default without LAV installed.  Works well now, thanks for listening...
Reply
#4
those will become the default settings beginning with the next release.
thanks!
Reply




Users browsing this thread: 1 Guest(s)