-->>Setup and usage<<--          
x.265 hardware acceleration with external GTX960
#1
Tongue 
Hi,

1st of all: thanks for this great codec and configuration utilities i'm using for years.

now i got an issue i cant solve by myself.

i'm using an external gpu (GTX 960) connected via the express card slot on my Thinkpad X220. The external monitor is connected to this card via HDMI and its working fine except the hardware decoding.  


i'm using Win10 64bit and trying to play the following video with windows media player:
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format-Profil                            : Main 10@L5@High
Codec-ID                                 : V_MPEGH/ISO/HEVC

i installed the standard codecs v4.92 and using the follwoing settings:

under H264/5: "USE LAV H264/5"
and configuration of LAV:
   

but while playing the file, the active decoder and active hardware accelerator don`t change there status and the CPU load of all cores comes up to 100%. i cannot change "the hardware device to use". maybe the LAV doesnt recognize the external connected gpu?

best regards from germany,
Ulli
Reply
#2
Try it with the (copy back) selection instead of native in LAV's settings
Reply
#3
(05-07-2017, 08:59 AM)Shark007 Wrote: Try it with the (copy back) selection instead of native in LAV's settings

doesn`t help

   
Reply
#4
My next suggestion would be to try using the MPC-BE player offered on my Tools page.
This player needs no configuration and will use the settings in mt App.
Reply
#5
(05-07-2017, 09:06 AM)Shark007 Wrote: My next suggestion would be to try using the MPC-BE player offered on my Tools page.
This player needs no configuration and will use the settings in mt App.

both, the x64 and x32 version, crash while trying to start playback of the mkv Sad


   
Reply
#6
Your hardware is most likely the issue here.
I cannot think of any other things to try.
Reply
#7
(05-07-2017, 09:17 AM)Shark007 Wrote: Your hardware is most likely the issue here.
I cannot think of any other things to try.

after restart its working with MPC-BE players. thanks!

do you have any idea why it isnt working unser WMP?
   
Reply
#8
good to hear it!

For WMP, press [Reset All] and then select the SUGGESTED settings.
Go to the H264/5 TAB and do not select LAV, just access its settings and make the changes you need.
The moment that you make a manual selection on that TAB, using MERIT is removed from the decoder chain which is setup by the suggested settings.
Go to the MKV TAB and disable Media Foundation there (assuming your file is an MKV)
Reply
#9
(05-07-2017, 09:56 AM)Shark007 Wrote: good to hear it!

For WMP, press [Reset All] and then select the SUGGESTED settings.
Go to the H264/5 TAB and do not select LAV, just access its settings and make the changes you need.
The moment that you make a manual selection on that TAB, using MERIT is removed from the decoder chain which is setup by the suggested settings.
Go to the MKV TAB and disable Media Foundation there (assuming your file is an MKV)

shark, you´re my hero! thank you thousand times! i won`t get it managed to find the right settings and restart every single time without your support!

one question beside: the win10 internal "tv&movies" programm is playing the file but without sound. it doesn`t even seems using LAV, because there are no items in the recognition bar.
is there any chance to play h265 movies with this player?
Reply
#10
The TV and Movies App does not use traditional codecs at all (directshow filters such as LAV). It uses a more recently developed technology called Media Foundation and finding developers interested in working on that to give us wider range of access like we have come used to with directshow is just not happening at this time.

The reason you have no sound with that App is that there is no DTS Media Foundation decoder available.
Reply




Users browsing this thread: 1 Guest(s)