Codecs for Technical Preview 9879,  Windows 7,  Windows 8.1
About Icaros - Printable Version

+- Codecs for Technical Preview 9879, Windows 7, Windows 8.1 (http://shark007.net/forum)
+-- Forum: Forum Listing (http://shark007.net/forum/Forum-Forum-Listing)
+--- Forum: Icaros Development (http://shark007.net/forum/Forum-Icaros-Development)
+--- Thread: About Icaros (/Thread-About-Icaros)



RE: About Icaros - Lenmaer - 03-15-2012

That's weird, it works for me on win7 x64.
What I did, uninstall the old one, kill explorer, install the new one, activate icaros. No reboot.


RE: About Icaros - BlackPhantom - 03-15-2012

Yea, I don't really know why it isn't working for me. I did all the same steps to uninstall 2.0 and reinstalled 1.3 and bam!, thumbnails appear like magic. So I don't really get why it isn't working for the 2.0.

The 2.0 doesn't require LAV filter last time I checked so I don't really see an issue. I don't have any codec packs other than DivX but I doubt that would cause Icaros 2.0 to not work.


RE: About Icaros - Xanashi - 03-15-2012

Oh! Thanks for all the feedback to all of you! ^_^

@Lenmaer
That is certainly possible. (I just usually can't stand when applications ask me to reboot, heh.) :-)

@cengizhan
Good to know it works for you. As I stated on the previous page, Flac is on it's way, and ogg, hmm...
I've already written an ogg parser to parse ogm/ogg videos, so it's certainly a possibility.

@BlackPhantom & BitTech
I'm currently unsure of what could be causing the problem you're experiencing.
But that's why this is a beta, so we can iron these things out before 2.0 goes public.
I'll get back to you as soon as I have done some more testing or compiled a debug build for you to test with.

@BitTech
Thanks for all the suggestions.
I'll keep them all in mind for the time being, and get back to them as soon as the initial problems have been resolved. :-)




RE: About Icaros - Lenmaer - 03-15-2012

Well, they're 2 others solutions like killing explorer or creating a run once startup entry so it would automatically finish the install after the next reboot without forcing it.


RE: About Icaros - Xanashi - 03-15-2012

(03-15-2012, 05:30 PM)Lenmaer Wrote:  Well, they're 2 others solutions like killing explorer or creating a run once startup entry so it would automatically finish the install after the next reboot without forcing it.

Indeed. I've personally always preferred to avoid any restarting, but it's usually the recommended way of doing things,
so I might have to go with it. Undecided






RE: About Icaros - Xanashi - 03-16-2012

Okay, so after doing a bit of investigative work today, it turned out I had forgotten to sign one of the x86 dlls.

This would surely had caused thumbnailing to fail on 32-bit systems.
Unfortunately, this still doesn't explain BlackPhantom's issue.

BitTech, I don't believe you mentioned the platform of your OS'?

Before I continue my investigation, please try this new beta 2 build,
and see if it resolves your problems.

Icaros 2.0 beta 2: Download (A newer version has been posted)

(The previous download links will be updated with the new build as well)

Also, upgrading from any previous build is not possible with the current installer.
I will try to see if I can implement proper upgrading before 2.0 goes public.




RE: About Icaros - BitTech - 03-16-2012

Beta2 still not working here. I am using 64-bit Win7 and Win8.


RE: About Icaros - Lenmaer - 03-16-2012

For me the beta 2 works without problem (as 1 did) on 7 x64.
Maybe there is a conflict between icaros and some codec packs for the people who it doesn't work?

Btw, it seems that the config panel reverted back to the old one in the beta 2.


RE: About Icaros - BlackPhantom - 03-16-2012

Beta 2 didn't work for me neither. I think I'll stick with my 1.3 until the cause is found. I'll be checking in and out and see if anything is new.

Thanks for your hard work.
I just notice something. When I install Icaros 1.3, it installs to my Program Files (x86) but when I install 2.0, it install to just my programs files, not my program files (x86).

Could that be the cause why it isn't working? Just throwing that out there.
Nope, installing to x86 folder didn't do it either.


RE: About Icaros - Xanashi - 03-16-2012

Hmm... still haven't gotten to the bottom of this.

@BitTech & BlackPhantom
After installing 2.0, does Explorer show the properties for your mkvs/ogms/flvs?
In other words, does the property handler work?
Icaros should always be installed into the "Program Files" directory by default. Both on 32 and 64 bit OS. Undecided

Lenmaer, in what way is the config panel reversed?