Codecs for Windows 10,  Windows 7,  Windows 8.1
Archived posts - Printable Version

+- Codecs for Windows 10, Windows 7, Windows 8.1 (http://shark007.net/forum)
+-- Forum: Forum Listing (http://shark007.net/forum/Forum-Forum-Listing)
+--- Forum: Icaros Development (http://shark007.net/forum/Forum-Icaros-Development)
+--- Thread: Archived posts (/Thread-Archived-posts)



RE: About Icaros - Lenmaer - 07-28-2012

Weird,
Thanks schwuppdiwupp.
Didn't think about demuxing it first then remuxing it as usually mkvtoolnix doesn't bug, except when you try to mux a m2ts file that has PCM audio into an MKV.


RE: About Icaros - ruudboek - 07-30-2012

Can icaros also support .swf files?
Only swf live preview is currently able to support it, but the tool is no longer developed and does not work with windows 7.


RE: About Icaros - Venti - 07-30-2012

Just installed this and it works great. Way faster than the default thumbnails in windows 7 too. Great job.

I did run into a bug related to UAC with the IcarosConfig though. I did not see this posted in the last few pages so I will report it here. The version I used is 2.1.0 beta 2.

When running as unpriviledged user, IcarosConfig is launched as an admin user, and as such it modifies the registry for that user. It still makes the thumbnails, even for the optional file types, but the thumbnail offset setting is ignored and 25% offset is used instead. This can be fixed by copying the [HKEY_CURRENT_USER\Software\Icaros] registry entry from the admins registry to the actual users registry, and modifying the offset directly in the actual users registry.


RE: About Icaros - Kovalchuk - 08-04-2012

Is it possible to add support for PNG transparency? Although, I guess Windows still will add its own shadowing (middle picture). ICO looks good, but if I attach/embed cover.ico Icaros treats it the same as PNG.

[Image: 1xheo.png]


RE: About Icaros - Medality - 08-07-2012

Oh man I just discovered this ! Showing covers from mkv files is so great !!!

But could you please add support for covers named "poster.jpg" ? I'm using RipBot264 and all my mkv's made with RipBot264 pre-1.17.3 contain this file.

It would be so awesome.

Anyway, thanks a lot for this great project !


RE: About Icaros - Xanashi - 08-08-2012

Hi Everyone,
Sorry for not being much around lately.
I've recently had some 'real life' things that required my full attention,
but from the end of this week and onwards, I should have more time to dedicate to the development of Icaros.

I hope people are still around :-)

All,
I have written down most bug reports and suggestions along the way,so everything will be added or fixed eventually,
but if you're worried about a bug you reported or a suggestion, that hasn't been fixed/done yet, let me know and I'll tell you the status.

ruudboek,
Unfortunately, FFmpeg currently only support a limited type of swf files.
Icaros has the same limitation, since it uses FFmpeg for thumbnailing.

Venti,
Thank you for reporting this.
I hadn't really considered this until I read your post.
This is most likely also the cause of the problem described in Shark's post on the previous page.
I will make sure to fix this.

Kovalchuk,
It should be quite easy to add transparency support to Icaros,
but to make it show up like the .ico file shown in your screenshot,
you will have to set a custom thumbnail adornment for that filetype,
which will remove filmstrip border from all non-cover mkvs.

I can tell you how to do this, if you wish to know, although it's not very useful until transparency is supported.

Medality,
You're welcome ^_^
I recently read RipBot264, changed it's naming convention of covers from poster.jpg to cover.jpg,
so using the latest version of RipBot264, should make compatible files (That's probably what you meant by 'pre-1.17.3', right?).

But for the sake of backwards compatibility, I'll add 'poster' as a keyword to Icaros too,
so that files created with previous versions of RipBot264 works, as well. ;-)


RE: About Icaros - xankazo - 08-08-2012

Of course we're still around! Smile


RE: About Icaros - FlyingHorse - 08-13-2012

In the Windows Application event log I am receiving Errors related to the .NET Runtime:
Code:
.NET Runtime version 4.0.30319.17929 - There was a failure initializing profiling API attach infrastructure.  This process will not allow a profiler to attach.  HRESULT: 0x80004005.  Process ID (decimal): 5980.  Message ID: [0x2509].
The process is always "SearchFilterHost.exe" when the IcarosPropertyHandler is loaded. If I disable Icaros the errors go away.
I am running Windows 7 x64 SP1 with the latest updates. I have also tested on a VMware Virtual Workstation running a clean installation of Windows 7 x64 SP1 and the same errors show up.

Could this be looked into? I would really like to eliminate these error messages so that I can quit getting alerts. I'll be glad to provide whatever assistance that I can.


RE: About Icaros - Xanashi - 08-13-2012

Hi FlyingHorse,

I currently don't have any errors like that and wasn't able to reproduce it either,
so if you could figure out a way to reproduce it, I will make sure to look into it.

@xankazo
Smile


RE: About Icaros - dsar - 08-14-2012

(08-13-2012, 01:29 PM)Xanashi Wrote: Hi FlyingHorse,

I currently don't have any errors like that and wasn't able to reproduce it either,
so if you could figure out a way to reproduce it, I will make sure to look into it.

@xankazo
Smile
Hi,

I see the same error in the eventlog (on Win7/64) - it disappears if I uncheck icaros for flv thumbnailing. As soon as I check flv and close icaros the event is logged