Codecs for Windows 10,  Windows 7,  Windows 8.1
Archived posts - Printable Version

+- Codecs for Windows 10, Windows 7, Windows 8.1 (http://shark007.net/forum)
+-- Forum: Forum Listing (http://shark007.net/forum/Forum-Forum-Listing)
+--- Forum: Icaros Development (http://shark007.net/forum/Forum-Icaros-Development)
+--- Thread: Archived posts (/Thread-Archived-posts)



RE: About Icaros - ruudboek - 12-16-2012

(12-16-2012, 02:24 PM)Xanashi Wrote: I suppose, I have to contact Marko again about this. Heh, just moments after confirming that the bug is gone. Oh well! ^_^

Well, you never know, maybe there is a bug somewhere that doesn't just affect cubicexplorer, but perhaps also other programs that we don't know of right now.
I haven't seen the problem in the windows explorer of windows xp though (tried different thumbnail sizes).

Ok, i have now also tried to kill explorer.exe just before the silent install of icaros starts, but it still generates this dialog message:

---------------------------

Confirm

---------------------------

The installation/removal of a previous program was not completed. You will need to restart your computer to complete that installation.

After restarting your computer, run Setup again to complete the installation of Icaros.

To complete the installation of Icaros, Setup must restart your computer.

Would you like to restart now?

---------------------------

Yes No

---------------------------

And this is the batchfile so far:

"c:\windows\system32\taskkill.exe" /f /t /im explorer.exe
c:\windows\temp\icaros\Icaros_v2.1.1.exe" /silent /components="icaros32"
"C:\Program Files\Icaros\IcarosConfig.exe" -deactivate
c:\windows\regedit.exe /s c:\windows\temp\icaros\thumbnailfiletypes.reg
"C:\Program Files\Icaros\IcarosConfig.exe" -activate

And yes, i can see explorer getting killed correctly.


RE: About Icaros - Xanashi - 12-16-2012

Try this:

"C:\Program Files\Icaros\IcarosConfig.exe" -deactivate
"C:\Windows\System32\taskkill.exe" /f /im explorer.exe
Start Explorer.exe
"C:\windows\temp\icaros\Icaros_v2.1.1.exe" /silent /components="icaros32"


RE: About Icaros - lordkag - 12-16-2012

@ruudboek
You are getting that message because you have not restarted your computer since the previous install of Icaros, meaning it is still pending. Restart and run this batch again, with the addition of -deactivate command, just in case.


RE: About Icaros - Xanashi - 12-16-2012

And lordkag is right. That is most likely your problem.
Thanks lordkag (very perceptive). ^_^

schwuppdiwupp,
I figured it out. I'll make sure to add this functionality to the next update of Icaros.
Thanks for the report.


RE: About Icaros - ruudboek - 12-16-2012

(12-16-2012, 03:04 PM)lordkag Wrote: @ruudboek
You are getting that message because you have not restarted your computer since the previous install of Icaros, meaning it is still pending. Restart and run this batch again, with the addition of -deactivate command, just in case.

I have restarted the computer and yes that worked. The only thing is that killing windows explorer seems to have messed up the deployed tool that i use to run the batchfile. I had to re-install the tool to get it to function again.

I don't know, but my guess is that a proper /norestart parameter would be a more civilized solution.


RE: About Icaros - Xanashi - 12-25-2012

Hi Everyone,

Here's little Christmas present to all of you.
I've recently been working on a couple of new features, which are almost ready for testing,
but before that, I thought it would be in order to get out a small stability build first.

There shouldn't be any regressions in this build, since 2.1.1, but just to make sure,
please give it test run, and let me know if anything comes up.
I'll release it as soon as I know it's regression free.


[Icaros v.2.1.2]
- Enabled Content View Properties
- Fixed thumbnailing and properties of certain Ape files
- Fixed parsing of legacy Monkeys Audio headers
- Fixed two minor bugs in Flac parser
- Flac cover art created with AIMP's Tag Editor (3.20.11635 and above), should now display
- Incremented the parsing threshold of the FLV Property parser (Should fix certain files that didn't show properties before)

Icaros 2.1.2 Installer: Download
Icaros 2.1.2 Portable: Download


Happy holidays to all of you! ^__^


RE: About Icaros - Lenmaer - 12-25-2012

Merry Christmas.

So far so good, I didn't notice any bugs in this release. I also can't say that I noticed any differences with 2.1.1, that's probably a good news as I doubt the corrected bugs concerned me. ^^


RE: About Icaros - ZavierQuixote - 12-25-2012

Thank you, Xanashi for developing a great program with Icaros. I tried the new version 2.1.2, and for some reason, flac files aren't showing tag information like they did with 2.1.1. I'm wondering if maybe it's because they were encoded with CUETools.FLACCL.cmd.exe? Or perhaps it could have something to do with the new AIMP's Tag Editor support for flac. I went back to the previous version, as it worked with it; I just wanted to mention this anomaly for development purposes. You have done an excellent job creating a solution to view thumbnails for media file types Windows Vista and above don't see fit to support. Thank you again for your work on Icaros.


RE: About Icaros - Xanashi - 12-26-2012

Thanks Lenmaer! ^_^
That was basically, what I was hoping you would say.
One fairly obvious change in 2.1.2, is that Icaros now shows properties in the 'Content View' mode of Explorer.

ZavierQuixote,
Thanks for the report!
I don't believe I have any sample files encoded by CUETools.FLACCL.cmd.exe,
so if you have one lying around, that could be a great help when troubleshooting.
Let me just look through the samples I have, and see if I can reproduce the problem you describe.

All,
I made a mistake in the last changelog.
The ID3v1 fix was actually not included in this particular build, it will be included later though.
The fix in this build was parsing of legacy Monkeys Audio headers.
I'll edit the changelog accordingly.


RE: About Icaros - ZavierQuixote - 12-26-2012

I tried to submit a very short sample flac file encoded with CueTools CUDA FLACCL#0.4 for review; however, I cannot as the page yields an error message saying "the type of file that you attached is not allowed. Please remove the attachment or choose a different type."