Codecs for Windows 10,  Windows 7,  Windows 8.1
Archived posts - Printable Version

+- Codecs for Windows 10, Windows 7, Windows 8.1 (http://shark007.net/forum)
+-- Forum: Forum Listing (http://shark007.net/forum/Forum-Forum-Listing)
+--- Forum: Icaros Development (http://shark007.net/forum/Forum-Icaros-Development)
+--- Thread: Archived posts (/Thread-Archived-posts)



RE: About Icaros - Xanashi - 04-28-2013

Could you link me to such a sample file or perhaps upload one?


RE: About Icaros - Xanashi - 05-01-2013

(04-28-2013, 07:31 AM)arrgh Wrote: Icaros does not show the cover of mkv files which are marked being "Stereomode = 13"...
... setting stereomode to "13" makes these files playable again in SP, but Icaros doesn't show the cover anymore...an other side effect seems to be, that MPC-BE does not play such patched files anymore (in 2D)...

Just tested this today in mkvmerge. To solve your problem, simply add ".mk3d" to the thumbnail filetypes list in IcarosConfig.
If you set any stereo mode besides null/mono, this extension will be used on the outputted mkv.


RE: About Icaros - Xanashi - 05-01-2013

Hi everyone,

It's been a while since the last Icaros update, and I think it's about time I let you all know, what I've been up to.

Since the previous beta release of Icaros, I've been working extensively on a new feature of Icaros.
I believe this new feature has finally reached a 'stable' alpha level.
All the basic functionality seems to be working fine on Windows 7, I did however find a small problem on Windows 8.
When this problem has been resolved, I intend to put up the alpha build for public testing.

In the meantime, I have also fixed a small number of bugs, and progressed on a number of other things on the todo list.
I hope to put out a final build of 2.2.1 with these bug fixes, right before the alpha build release. Or maybe right after. :)


If anyone is curious about the new feature and interested in a little bit of pre-alpha testing on Win7 or Vista, just give me a call at Xanashi[at]gmail.com.
The only requirement is: Provide feedback after testing.


RE: About Icaros - arrgh - 05-03-2013

(04-28-2013, 08:30 AM)Xanashi Wrote: Could you link me to such a sample file or perhaps upload one?

sorry for not having answered immediately but it took me some time to realise what the problem was...
I couldn't reproduce the reported "bug" because meanwhile I had installed version 2.2.1...all mkv-files showed a cover and I could not break it anymore by setting the stereomode....
after some time I realised that an other PC, which still had version 2.2.0 installed still showed the problem, after updating to 2.2.1 it was gone on this PC too...

so basically the problem ist solved with 2.2.1...


RE: About Icaros - danei - 05-09-2013

Hi Xanashi:
Can you do something to optimize thumbnail generating for images? I have some big tiff from panorama stitching, and Icaros takes minutes and more than 3GB ram to generate thumbnail for a 1GB 16bit tiff, while honeyview takes seconds and about 500MB ram to open the file.

BTW, the tiff files are on SSD so reading speed is not bottleneck.


RE: About Icaros - Xanashi - 05-09-2013

Hi danei,

It really depends on FFmpeg. But 3GB ram and several minutes?
If I can find a 1 GB tiff sample somewhere, I will take a look at it.


RE: About Icaros - Xanashi - 05-09-2013

@danei,
I was able to find and fix a possible bug, that may or may not help lower the resources used.
Could you provide me with some specifics of one of your tiff files?
Perhaps a Mediainfo log output?


RE: About Icaros - danei - 05-09-2013

(05-09-2013, 05:41 AM)Xanashi Wrote: @danei,
I was able to find and fix a possible bug, that may or may not help lower the resources used.
Could you provide me with some specifics of one of your tiff files?
Perhaps a Mediainfo log output?
Hi Xanashi:
The tiff looks like this:
Image
Format : LZW
Width : 16 260 pixels
Height : 4 808 pixels
Color space : RGB
Bit depth : 16 bits / 16 bits / 16 bits / 16 bits
Compression mode : Lossless

BTW, Icaros' thumbnail is a little greenish compared to what they look in lightroom. The problem might lies in colorspace, the embed colorspace is AdobeRGB while system's color space is sRGB.


RE: About Icaros - Xanashi - 05-10-2013

Thanks for the details.

(05-09-2013, 08:38 PM)danei Wrote: BTW, Icaros' thumbnail is a little greenish compared to what they look in lightroom. The problem might lies in colorspace, the embed colorspace is AdobeRGB while system's color space is sRGB.

This is a bug in FFmpeg. I've reported it some weeks ago.
They've created a ticket for it in the bug tracker.


RE: About Icaros - hamedjoon - 05-10-2013

Please add ADTS filetype