Codecs for Windows 10,  Windows 7,  Windows 8.1
Archived posts - Printable Version

+- Codecs for Windows 10, Windows 7, Windows 8.1 (http://shark007.net/forum)
+-- Forum: Forum Listing (http://shark007.net/forum/Forum-Forum-Listing)
+--- Forum: Icaros Development (http://shark007.net/forum/Forum-Icaros-Development)
+--- Thread: Archived posts (/Thread-Archived-posts)



RE: About Icaros - Xanashi - 04-30-2014

I couldn't find the time yesterday, but here we are.
This build should fix a couple of regressions, as well as a few new bugs (mostly related to Win8).

[Icaros v.2.2.5 Beta 2]
- Fixed thumbnailing of png cover art
- Fixed SSE incompatibility
- Fixed association bug on Windows 8.1 Update 1
- Fixed parsing of properties in some incomplete mkv files on Windows 8
- Fixed thumbnailing of some incomplete mkv files on Windows 8
- Cleaned up a bit more

Icaros 2.2.5 Beta 2 Installer: Download
Icaros 2.2.5 Beta 2 Portable: Download


RE: About Icaros - Xanashi - 04-30-2014

(04-29-2014, 12:56 AM)moob Wrote: yes, some of my files not generate thumbnails with 2.2.4/2.2.5, I have to deactivate and activate Icaros to generate thumbnails in some mp4 and mkv files.

This past week I've done a lot of testing with 2.2.5 on various versions of Windows 8, including Windows 8.1 Update 1,
and at no time did I run into issues with normal thumbnailing.

Please try the latest beta build (post above), and let me know if it fixes your problem.

Quote:But with 2.3.0 Alpha 2 I do not have this problem.

Again, 2.3.0A2 and 2.2.4 are the exact same build internally, only the GUI is different.
IcarosConfig in 2.3.0A2 does handle some things slightly different,
such as filetype registrations while Icaros is activated,
but the end result should be the same.


RE: About Icaros - kerimcem - 04-30-2014

to be repaired?
http://forums.mydigitallife.info/threads/48551-Plz-help-how-to-stop-deletion-of-thumbnail-cache-in-windows-8-and-8-1

1-3 day delete cache win8.1 Sad 50mb+


RE: About Icaros - idkwho - 05-14-2014

Hi, I am using windows 7 x64 and the latest build 2.25 beta 2 but I still get the COM SURROGATE has stopped working every time I open a folder which is still downloading mkv files/generating thumbnails.

Faulting application name: DllHost.exe, version: 6.1.7600.16385
Faulting module name: swscale-ics-2.dll, version: 2.5.101.0

Faulting application path: C:\Windows\system32\DllHost.exe
Faulting module path: C:\Program Files\Icaros\64-bit\swscale-ics-2.dll

Could you fix this please?


RE: About Icaros - Shark007 - 05-14-2014

(05-14-2014, 05:34 AM)idkwho Wrote: Hi, I am using windows 7 x64 and the latest build 2.24 but I still get the COM SURROGATE has stopped working every time I open a folder which is still downloading mkv files/generating thumbnails.

Could you fix this please?

uninstall the Divx.com Codec pack and Icaros.
Reboot your computer and re-install Icaros.
The Divx.com software is most likely the cause of your issue.


RE: About Icaros - hervansaputra - 05-25-2014

COM SURROGATE error

General
Unique ID : 196028711848776036853269692897949380079 (0x9379C1B140DB842EA92DD5B35B6BEDEF)
Complete name : D:\Download\Video\Anime\No Game No Life\NGNL_03_HD_U-FFF_ACB.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 123 MiB
Duration : 23mn 46s
Overall bit rate : 721 Kbps
Movie name : [AnimeChiby] No Game No Life - 03
Encoded date : UTC 2014-04-24 04:11:58
Writing application : mkvmerge v6.8.0 ('Theme for Great Cities') 64bit built on Mar 2 2014 21:34:26
Writing library : libebml v1.3.0 + libmatroska v1.4.1
Attachment : Yes / Yes / Yes / Yes / Yes / Yes / Yes / Yes

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.0
Format settings, CABAC : Yes
Format settings, ReFrames : 10 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 23mn 46s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Writing library : x264 core 130 r2273 b3065e6
Encoding settings : cabac=1 / ref=10 / deblock=1:1:1 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / psy_rd=0.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=8 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=crf / mbtree=1 / crf=25.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Language : English
Default : Yes
Forced : No
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : HE-AAC / LC
Codec ID : A_AAC
Duration : 23mn 46s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz / 24.0 KHz
Compression mode : Lossy
Delay relative to video : 31ms
Language : Japanese
Default : Yes
Forced : No

Text
ID : 3
Format : SSA
Codec ID : S_TEXT/SSA
Codec ID/Info : Sub Station Alpha
Compression mode : Lossless
Language : English
Default : Yes
Forced : No

Menu
00:00:00.000 : en:Intro
00:00:30.322 : en:Opening
00:01:59.995 : enTongueart A
00:11:00.118 : enTongueart B
00:22:09.995 : en:Ending
00:23:39.960 : en:Next Episode Preview

the sub making the crash i think.
heres link for the video https://mega.co.nz/#!f1gwkTYb!MWF41F1KJt37p1YD3dOrXgmaTXsOeTUo3FpKZbUryzA


RE: About Icaros - Xanashi - 05-25-2014

Hi hervansaputra,

I tried thumbnailing the file with the latest beta 2.2.5b2, and couldn't reproduce the crash on neither Win7 nor Win8.

What version of Icaros do you currently have installed?


RE: About Icaros - Xanashi - 05-25-2014

Hi idkwho,

Sorry for the delay.
I don't suppose you have a sample, that generates the error?


RE: About Icaros - Xanashi - 05-25-2014

kerimcem,

Unfortunately that's not something I can fix on my end.
This problem has been around for some time now (in Windows 7 and I believe Vista too),
but has worsened in Windows 8, due to the new way the system requests and caches its thumbnails.

I'm not sure if this is actually the intended behavior or simply an oversight on Microsofts end,
however considering this problem has been around for so long, and has been reported several times to MS, it may just be the former.


RE: About Icaros - hervansaputra - 05-25-2014

(05-25-2014, 03:13 AM)Xanashi Wrote: Hi hervansaputra,

I tried thumbnailing the file with the latest beta 2.2.5b2, and couldn't reproduce the crash on neither Win7 nor Win8.

What version of Icaros do you currently have installed?

same version.
i'm using 8.1 btw.
any solution..?? :/