-->> Shark's website <<--

Shark's Help Forum

  Create an account  
Laptop using mostly Intel UHD instead of RTX 3060 for DXVA?

I've been using Shark for years.  It's always been my go-to for many many reasons.  I always use LAV and enable DXVA for x264/65 and many other formats. 

I'm getting some issues with my MSI gaming laptop.  The video is RTX 3060, pretty much capable of everything. 

I have LAV set for all formats of video basically and DXVA set to use the 3060.  When I'm playing an MKV in WMPx64 however, sometimes it's stuttering and not using the 3060 at all.  In addition when I don't get that stuttering, task manager says that the on-chip Intel UHD graphics are using like 30+% and the 3060 is only at like 12%? 

This morning I updated the UHD, Shark, and GeForce drivers to latest available as of today, 2.10.22. 

So...the question becomes where do I go from here to figure out whats happening and why?

Open the 64bit Application and press [Reset ALL]
Go to the MKV tab and choose to disable Media Foundation for MKV
test with no other changes

In the Nvidia Control Panel, under manage 3D settings
you can select a preferred gpu - check that setting, it works for more than just 3D

I have noticed  even with the above setting that WMP will still use the Intel GPU on the laptop screen
where as MPC-BE player from my tools page, will use the Nvidia gpu (my laptop is quite old)
If you open the LAV video settings from the tray icon during playback, it will tell you what gpu it is connected to.

Also look around for G-Sync in the Nvidia settings and turn that off

Just in case you were selecting to use CUVID, stop doing that.
D3D11 is what you want to be using.

Thanks for the reply.

I just figured out what caused it.

The laptop display is 144hz.  My 55" 1080p/60hz  TV is connected via HDMI.  2 days ago I changed the laptop display to 144 from being on 60 for quite some time.  When using the laptop as my primary display and working off it primarily, I can feel a nice difference between 60 and 144hz when using the mouse. 

When I just put the laptop screen back to 60hz, this whole problem disappears.

OK little update

What I'm actually trying to do is disable the laptop display at night while watching MKVs on the TV.  I use Windows Key + P to disable the laptop display.  So with only the TV available for display, I still have to disable the UHD integrated graphics via Device Manager to avoid stuttering on MKVs.  This forces LAV or MPE decoder to use the RTX 3060. 

As for your suggestions settings wise, I always disable all MS and "standard" decoders, DMO, Media Foundation, etc.  However, on the Swap page, I can't enable the "disable MS video decoder" option.  I get the warning to move all desktop videos into a folder, sign out, etc.  I don't have any videos on my desktop. 

If you have any more insights or suggestions, I'm very grateful, thanks.

I have experienced this same issue on Windows 11.
You'll need to boot in to Safe Mode to get it disabled.

Users browsing this thread:
2 Guest(s)