mp4 files with HEVC and AAC codec broken when AC3 enabled - Printable Version

+- (https://shark007.net/forum)
+-- Forum: Choose a topic below (https://shark007.net/forum/Forum-Choose-a-topic-below)
+--- Forum: ADVANCED Codecs (https://shark007.net/forum/Forum-ADVANCED-Codecs)
+--- Thread: mp4 files with HEVC and AAC codec broken when AC3 enabled (/Thread-mp4-files-with-HEVC-and-AAC-codec-broken-when-AC3-enabled)



mp4 files with HEVC and AAC codec broken when AC3 enabled - ctorbaoglu - 10-13-2020

Hello,

There is a problem on Advanced Codecs since version 14. And it still continues on ver.14.1.4.
Enabling AC-3 breaks .mp4 files with HEVC and AAC codec. The video files doesn't start when uncheck the Disable AC-3 checkbox.


RE: mp4 files with HEVC and AAC codec broken when AC3 enabled - Shark007 - 10-13-2020

On the MP4 tab, you need to [x] disable Media Foundation for MP4
If you have done that already, try using the MPC-BE splitter for MP4 on that same tab.


RE: mp4 files with HEVC and AAC codec broken when AC3 enabled - zelroy - 11-06-2020

(10-13-2020, 02:40 PM)Shark007 Wrote: On the MP4 tab, you need to [x] disable Media Foundation for MP4

I've been meaning to ask. Why is that not disabled by default? Seems to me that Windows Media Foundations sucking is one big, if not the biggest reasons to use these codecs in the first place. I can't think of many reasons why someone would want to use these codecs but have Windows Media Foundations enabled. It's the one setting I have to change after every update.

I would suggest disabling Windows Media Foundations to be the default setting after installation / update.


RE: mp4 files with HEVC and AAC codec broken when AC3 enabled - Shark007 - 11-06-2020

It is only required to be disabled if you are using WMP
If you were to check the box, [x] WMP suggested settings, it gets disabled.
That checkbox does a thousand other things that are only available by checking that box.


RE: mp4 files with HEVC and AAC codec broken when AC3 enabled - zelroy - 11-06-2020

(11-06-2020, 10:45 AM)Shark007 Wrote: It is only required to be disabled if you are using WMP
If you were to check the box, [x] WMP suggested settings, it gets disabled.
That checkbox does a thousand other things that are only available by checking that box.

Yeah, isn't using WMP and not having to install another media player another big reason to use these codecs?

The last time (a long time ago) I tested WMP suggested settings my multichannel audio stopped working. I guess I'll have to test it again.


RE: mp4 files with HEVC and AAC codec broken when AC3 enabled - Shark007 - 11-06-2020

That checkbox only recently has the WMP designation attached to it.
It used to just read suggested settings.


RE: mp4 files with HEVC and AAC codec broken when AC3 enabled - ctorbaoglu - 11-11-2020

(11-06-2020, 10:31 AM)zelroy Wrote:
(10-13-2020, 02:40 PM)Shark007 Wrote: On the MP4 tab, you need to [x] disable Media Foundation for MP4

I've been meaning to ask. Why is that not disabled by default? Seems to me that Windows Media Foundations sucking is one big, if not the biggest reasons to use these codecs in the first place. I can't think of many reasons why someone would want to use these codecs but have Windows Media Foundations enabled. It's the one setting I have to change after every update.

I would suggest disabling Windows Media Foundations to be the default setting after installation / update.


Yes, Video files (Hevc + AC-3 ones) not play with WMP when AC-3 enabled. But last 3 versions disabling Media foundation doesn't help. I figured out when, I checked the box on, Audio Tab > AC-3 Config  > System > Disallow PCM output in SPDIF mode, the problem solved.

On the other hand, When "Media Foundation for MP4"  disabled, WMP displays the portrait videos (recorded by phones) in the wrong orientation as videos playing right tilted. If Media Foundation not disabled, this time MP4 movies not showing subtitles.


RE: mp4 files with HEVC and AAC codec broken when AC3 enabled - Shark007 - 11-11-2020

Disallow PCM output in SPDIF mode <--- added as a default setting

MP4 that gets the aspect ratio wrong
try in LAV decoder settings on Configure tab, 
upper left - make changes here ...  [x] use stream aspect ratio