AC3 Filter problem / WMP tilted video when MF Disabled - Printable Version

+- (https://shark007.net/forum)
+-- Forum: Choose a topic below (https://shark007.net/forum/Forum-Choose-a-topic-below)
+--- Forum: ADVANCED Codecs (https://shark007.net/forum/Forum-ADVANCED-Codecs)
+--- Thread: AC3 Filter problem / WMP tilted video when MF Disabled (/Thread-AC3-Filter-problem-WMP-tilted-video-when-MF-Disabled)



AC3 Filter problem / WMP tilted video when MF Disabled - ctorbaoglu - 11-11-2020

Hello Shark,
Hope you are fine. I just format the PC to start from scratch but unfortunately last couple of versions I found issues as follows; (WMP suggested settings enabled)

1- When "Media Foundation for MP4"  disabled, WMP displays the portrait videos (recorded by phones) in the wrong orientation as videos playing right or left tilted. If Media Foundation not disabled, this time MP4 movies not showing subtitles.

2- Video files (HEVC + AC3) and (AVC + AC3), (AVC+AAC), (AVC+E-AC3) not play with WMP when AC-3 enabled. I figured out when, I checked the box on, Audio Tab > AC-3 Config  > System > Disallow PCM output in SPDIF mode, the problem solved.

3- But neither this nor checking AC3 on AC3 Config doesn't allow Ac3 files handled by the decoder. When I look at the sys tray I see that all handled by LAV. So, 1st I enabled AC3 Filter, and checked to use AC3 Filter for AC3 and AAC on System tab of AC3 Filter config but AC3, files never encoded by AC3 filter. (BTW: Prefer AC Filter is selected on Filter merit). (See: attracted pics).

Thank you for your effort and recommendations.
Warm Regards,

(11-11-2020, 05:37 PM)ctorbaoglu Wrote: Hello Shark,
Hope you are fine. I just format the PC to start from scratch but unfortunately last couple of versions I found issues as follows; (WMP suggested settings enabled)

1- When "Media Foundation for MP4"  disabled, WMP displays the portrait videos (recorded by phones) in the wrong orientation as videos playing right or left tilted. If Media Foundation not disabled, this time MP4 movies not showing subtitles.

2- Video files (HEVC + AC3) and (AVC + AC3), (AVC+AAC), (AVC+E-AC3) not play with WMP when AC-3 enabled. I figured out when, I checked the box on, Audio Tab > AC-3 Config  > System > Disallow PCM output in SPDIF mode, the problem solved.

3- But neither this nor checking AC3 on AC3 Config doesn't allow Ac3 files handled by the decoder. When I look at the sys tray I see that all handled by LAV. So, 1st I enabled AC3 Filter, and checked to use AC3 Filter for AC3 and AAC on System tab of AC3 Filter config but AC3, files never encoded by AC3 filter. (BTW: Prefer AC Filter is selected on Filter merit). (See: attracted pics).

Thank you for your effort and recommendations.
Warm Regards,



Hello,

I just download and tried v.14.2.9.0. I found so far as follows. (WMP suggested settings enabled and all videos I tried are MKV (excl. AVC+AAC which is MP4));

Well, WMP still displays the portrait videos (recorded by phones) in the wrong orientation as tilted, if Media Foundation disabled.
If I enabled WM Foundation, all but AVC+AAC displays the subtitles but none of them handled by AC3 Filter.


-- When AC3 Filter enabled >
* AVC+AC3 plays OK but, AC3 not handled by AC3 Filter,

* HEVC+AC3 plays OK but, AC3 not handled by AC3 Filter,

* AVC+AAC plays OK and AAC handled by AC3 Filter,

* HEVC+AAC plays OK and AAC handled by AC3 Filter,

* AVC+E-AC3 broken, not play

-- When AC3 Filter enabled and AC3 checked (along with the AAC) in AC Filter Config > System tab ,
* AVC+AC3 broken, not play unless disable (checked) the "Disallow PCM output in SPDIF mode" setting in AC3 Config > System
          (but sound(AC3) still not handle by AC3 Filter),
* HEVC+AC3 broken, not play, unless disable (checked) the "Disallow PCM output in SPDIF mode" setting in AC3 Config > System
          (but sound(AC3) still not handle by AC3 Filter),
* AVC+AAC and HEVC+AAC both plays ok and AC3 also ok
* AVC+E-AC3 broken, not play unless disable (checked) the "Disallow PCM output in SPDIF mode" setting in AC3 Config > System
          (but sound(AC3) still not handle by AC3 Filter),
(AVC+AAC and HEVC+AAC
Thank you.


RE: AC3 Filter problem / WMP tilted video when MF Disabled - Shark007 - 11-11-2020

If you want AC3Filter to handle everything choose to [Disable LAV audio]
Also make sure the Microsoft Audio decoder is disabled.
Then go into AC3Filters settings and enable everything.