-->> Shark's website <<--

Shark's Help Forum

Search
  Create an account  
New Release: 3.3.1 Final

#11
Hi javacatpaul,

I can't confirm 1.
I've just tested it on two systems Win10 and Win11 and Icaros properly restored the original property handler on deactivation.
Both when just deactivating a single filetype as well as when deactivating the property handler.

I'll be sure to look into 2.
Icaros should be returning proper LENGTH properties with just about any valid mp4/m4a file,
so it would be odd if that was the problem. To fix it I would probably need info on what exactly is 
preventing WMPTAGPLUS from reading the properties with Icaros enabled.

EDIT: Would it be possible for you to send me an m4a file that doesn't work with Icaros+WMPTAGPLUS?
Reply

#12
re: #1

  my box is Win 7, yeah I know...

 I confirmed several times, it does del thoses 2 reg entries on my sys.  

I did notice that icaros has a reg entry where it saves a backup of prev guids, called PropBackup.  On mine 
all are set to icaros' own guid, and there is no entry for m4a at all (nor mp4).   Speculation, but perhaps at
 an earlier date I updated Icaros version and its backup  snapshot'd the already set icaros values?  But the 
default guids are "well known" for years now, they're prob hard coded in there at this point.  

It's a mystery.... 

re: #2

  it's all m4a's, none get recognized at all.  I'll make a tiny one this afternoon and reconfirm and attach it to you...

Thanks for looking into it!

-=PSH=-
Reply

#13
First, I did recheck the issue of the reg entries being deleted rather than restored; this time I watched carefully via regedit [again!] and I CAN NOT REPEAT IT!  Today it DOES set AND RESTORE just fine!   I just do not know...but it
was not Icaros' fault I am now sure - sorry for misleading.  I will continue to fuss to find the culprit, I will enable a reg-monitor to keep an eye on it.

Second, here's a little sample file, its tag is like all the rest of my m4a, created by mp3tag 3.22 today.  If I have the Icaros handler choosen then WMP+WMPTAGPLUS adds it to "Other Media" and not "Music"; uncheck Icaros handler and rebuild WMP library and they all come back into "Music".  There's something that wmptagplus does not like.

Thanks again!
Reply

#14
Hi javacatpaul,

Sorry for the slow reply. 

1) There was a bug in an earlier version of Icaros where double registration could cause Icaros to overwrite the backup values,
with its own GUIDs. However it has been fixed for some time now. Maybe your backup keys was still overwritten from back then,
and now that you've fixed them, everything works as intended. 

2) I'll investigate further. I can't seem to see your sample file, are you sure it was attached to your post?
Reply

#15
i'll try again


Attached Files
.zip   sample.zip (Size: 47.3 KB / Downloads: 64)
Reply

#16
Thanks for the sample! 

I tried testing on a fresh install of Windows 11, and I couldn't make it fail.
See this screenshot. Icaros properties is enabled for M4a, and WMPTAGPLUS is installed. 
M4a is still showing in Music, and allows editing of properties. The screenshot contains your sample and another M4a sample file.

   

Is there anything else I need to do before testing?
Reply

#17
The only thing I can think of is to wipe the music lib and try from scratch, that's how I usually check.
in wmp,  Tools | Advanced | Restore Media Libray, which will del lib and exit, then on restart of WMP 
it'll rebuild.  On mine if icaros is checked all m4a's end up in Other Media, if unchecked they go into Music as 
expected; very repeatable.   My W7 could well have other issues of course, but it checks out for the most part [sfc /scan now etc all ok], and has all ESU updates thru Oct'23.   I supose I could try a full remove of icaros, wmptagplus,  and then wmp, reset all defaults via codectweaktool,  and then reinstall and re-reg wmp and then icaros and see how it goes...on a rainy day perhaps!

Thanks for chasing the issue, I'll keep digging at my end.   We'll all be on Windows 13 soon I suppose...

-=PSH=-
Reply

#18
Ah,  Icaros 3.3.2 is out and It works just fine, m4a's prop handler works for me again!

Thanks for your efforts, as always!
Reply

#19
(11-22-2023, 01:48 PM)javacatpaul Wrote: Ah,  Icaros 3.3.2 is out and It works just fine, m4a's prop handler works for me again!

Thanks for your efforts, as always!

That is awesome to hear! 
I did make some changes to the MOV/MP4 prop handler, so hopefully one of these changes fixed it.
So happy you got it working.
Reply





Users browsing this thread:
1 Guest(s)