-->> Shark's website <<--

Shark's Help Forum

Search
  Create an account  
Green screen when playing x265 content

#1
Hi,

I'm a long time Win8/EMBY Media Centre/Sharks users. I use the standard codec pack as all I want installed is LAV and VobSub.

I use an intel NUC 5i3RYH which has worked perfectly with the old setup until I did this today.

I had an issue where subtitles stopped rendering - assume some Win8 update screwed that up like usually happens.

I decided I should update my Shark007 codecs while I was looking at this so I uninstalled the old 9.90 versions I had installed ages ago and decided to try the portable versions.

I ran both the 64bit and 32bit standalones and thought everything looked ok in the options. However i'm getting an issue now when I try and play any x265 mkv's.

When I try and play a movie encoded in x265 the audio plays fine however I'm getting 3 copies of the video overlayed side by side and they are all green - as per the attached screenshot.

I had this problem last year or whenever it was I previously installed Sharks and I found a post on the forums here that told me some setting needed to be switched off or on to fix this but I can no longer seem to find that old post. The video will display green regardless of if im trying to play in Emby or in Windows Media Player (or anything which doesn't use its own internal renderer/codecs)

Things ive tried so far:
- Changing the Hardware Decoding to DXVA2 (Loop back), DXVA2 (Native), Intel quicksync (old) and DX3d11 - still green screen in all instances.
- Unticking and ticking the WMP suggested settings checkbox
- Trying Fix Permissions button

Hoping someone might be able to tell me what im missing - something stupid i'm guessing.


Attached Files Thumbnail(s)
   
Reply

#2
In the 64bit Settings Application, press [Reset All]
Test with no changes.
Reply

#3
ok just tried that... no difference... still get the 3 overlapping vids hidden behind the green filter
Reply

#4
On the 64bit Swap TAB, choose to disable the Microsoft Video Decoder.
Reply

#5
ok just tried that and still no change.
Reply

#6
I cannot reproduce your issue.
On the Misc TAB, use the button to [Analyze a media file] on that particular file.
Post that output here.
Reply

#7
attached is the output from the analysis

it seems its not ALL x265 files.

here is the output from the analysis of one that works... this is a 720p tv episode... the ones that are turning green are 1080p movies....



Attached Files
.txt   iceroad.txt (Size: 4.24 KB / Downloads: 239)
.txt   masterchef.txt (Size: 5 KB / Downloads: 245)
Reply

#8
I do not see anything out of the ordinary in there.
DO you know what player is being used? I wonder if it is a 32bit player.
In the 32bit App, choose to disable the Microsoft Video decoder there also.
Reply

#9
im using Microsoft Media Center on Windows 8 and then using the Emby Media Center app within WMC to play the files.

It was all working fine up until this morning when I updated from 9.90 installed to the latest portable Sad

Ill try win32 settings now and get back to you.
Reply

#10
It does seem to me that playback is not using the LAV decoders.
Reply





Users browsing this thread:
1 Guest(s)